diff options
author | Florian Weimer <fweimer@redhat.com> | 2018-08-20 14:57:13 +0200 |
---|---|---|
committer | Florian Weimer <fweimer@redhat.com> | 2018-08-20 14:57:13 +0200 |
commit | 35cfefd96062145eeb8aee6bd72d07e0909a6b2e (patch) | |
tree | 2ae287f876cd5eb42dffbfff47f19f19c95a2c0d | |
parent | powerpc: Remove powerpc specific sinf and cosf optimization (diff) | |
download | glibc-35cfefd96062145eeb8aee6bd72d07e0909a6b2e.tar.gz glibc-35cfefd96062145eeb8aee6bd72d07e0909a6b2e.tar.bz2 glibc-35cfefd96062145eeb8aee6bd72d07e0909a6b2e.zip |
malloc: Add ChangeLog for accidentally committed change
Commit b90ddd08f6dd688e651df9ee89ca3a69ff88cd0c ("malloc: Additional
checks for unsorted bin integrity I.") was committed without a
whitespace fix, so it is adjusted here as well.
-rw-r--r-- | ChangeLog | 4 | ||||
-rw-r--r-- | malloc/malloc.c | 2 |
2 files changed, 5 insertions, 1 deletions
@@ -20,6 +20,10 @@ * sysdeps/s390/fpu/libm-test-ulps: Regenerate. +2018-08-17 Istvan Kurucsai <pistukem@gmail.com> + + * malloc/malloc.c (_int_malloc): Additional binning code checks. + 2018-08-16 Florian Weimer <fweimer@redhat.com> * configure.ac: Add --with-nonshared-cflags option. diff --git a/malloc/malloc.c b/malloc/malloc.c index 47795601c8..67cdfd0ad2 100644 --- a/malloc/malloc.c +++ b/malloc/malloc.c @@ -3730,7 +3730,7 @@ _int_malloc (mstate av, size_t bytes) if (__glibc_unlikely (bck->fd != victim) || __glibc_unlikely (victim->fd != unsorted_chunks (av))) malloc_printerr ("malloc(): unsorted double linked list corrupted"); - if (__glibc_unlikely (prev_inuse(next))) + if (__glibc_unlikely (prev_inuse (next))) malloc_printerr ("malloc(): invalid next->prev_inuse (unsorted)"); /* |