aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>1997-08-29 21:52:14 +0000
committerBarry Warsaw <barry@python.org>1997-08-29 21:52:14 +0000
commitdd82bb9c14eee9a66b2172f11638d9f7dec8d8b8 (patch)
treeb6d8407b6b2e5f4741d37dfaf553c0415c14e840 /Makefile.in
parentSubtle changes to the AIX shared library things to make them work (diff)
downloadcpython-dd82bb9c14eee9a66b2172f11638d9f7dec8d8b8.tar.gz
cpython-dd82bb9c14eee9a66b2172f11638d9f7dec8d8b8.tar.bz2
cpython-dd82bb9c14eee9a66b2172f11638d9f7dec8d8b8.zip
Added a new variable TESTPYTHON which contains the path (and args) for
the executable to use during regression testing.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 2bf9eb95dfb..0a26902ad4e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -200,10 +200,11 @@ Modules: Parser Python Objects
# Test the interpreter (twice, once without .pyc files, once with)
TESTOPTS=
TESTPROG= $(srcdir)/Lib/test/regrtest.py
+TESTPYTHON= ./python
test: python
-rm -f $(srcdir)/Lib/test/*.pyc
- -PYTHONPATH= ./python $(TESTPROG) $(TESTOPTS)
- PYTHONPATH= ./python $(TESTPROG) $(TESTOPTS)
+ -PYTHONPATH= $(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
+ PYTHONPATH= $(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
# Install everything
install: altinstall bininstall maninstall