aboutsummaryrefslogtreecommitdiff
path: root/sim/ft32
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-03 21:40:34 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-03 22:07:39 -0500
commit77cf2ef5dc9099501529151921a73be904757466 (patch)
treeafe55fc45fb53886d73ed81e984f83222ab759a7 /sim/ft32
parentsim: TODO: move to wiki (diff)
downloadbinutils-gdb-77cf2ef5dc9099501529151921a73be904757466.tar.gz
binutils-gdb-77cf2ef5dc9099501529151921a73be904757466.tar.bz2
binutils-gdb-77cf2ef5dc9099501529151921a73be904757466.zip
sim: parse_args: display getopt error ourselves
Fix a long standing todo where we let getopt write directly to stderr when an invalid option is passed. Use the sim io funcs instead as they go through the filtered callbacks that gdb wants.
Diffstat (limited to 'sim/ft32')
-rw-r--r--sim/ft32/ChangeLog4
-rw-r--r--sim/ft32/interp.c4
2 files changed, 5 insertions, 3 deletions
diff --git a/sim/ft32/ChangeLog b/sim/ft32/ChangeLog
index 3a1acccf85f..03235f58131 100644
--- a/sim/ft32/ChangeLog
+++ b/sim/ft32/ChangeLog
@@ -1,5 +1,9 @@
2016-01-03 Mike Frysinger <vapier@gentoo.org>
+ * interp.c (sim_open): Update sim_parse_args comment.
+
+2016-01-03 Mike Frysinger <vapier@gentoo.org>
+
* configure.ac (SIM_AC_OPTION_HOSTENDIAN): Delete.
* configure: Regenerate.
diff --git a/sim/ft32/interp.c b/sim/ft32/interp.c
index ec019b30948..a2d59b0784b 100644
--- a/sim/ft32/interp.c
+++ b/sim/ft32/interp.c
@@ -807,9 +807,7 @@ sim_open (SIM_OPEN_KIND kind,
return 0;
}
- /* getopt will print the error message so we just have to exit if this fails.
- FIXME: Hmmm... in the case of gdb we need getopt to call
- print_filtered. */
+ /* The parser will print an error message for us, so we silently return. */
if (sim_parse_args (sd, argv) != SIM_RC_OK)
{
free_state (sd);