aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2020-07-08 21:21:32 +0930
committerAlan Modra <amodra@gmail.com>2020-07-09 22:58:16 +0930
commitfe49679d5193f6ff7cfd333e30883d293112a3d1 (patch)
treed3e22fb7645b021227855dbde32c85a9b6fe0a0b /ld/emultempl/beos.em
parentpowerpc garbage collect test (diff)
downloadbinutils-gdb-fe49679d5193f6ff7cfd333e30883d293112a3d1.tar.gz
binutils-gdb-fe49679d5193f6ff7cfd333e30883d293112a3d1.tar.bz2
binutils-gdb-fe49679d5193f6ff7cfd333e30883d293112a3d1.zip
Remove powerpc PE support
Plus some leftover powerpc lynxos support. bfd/ * coff-ppc.c: Delete. * pe-ppc.c: Delete. * pei-ppc.c: Delete. * Makefile.am (BFD32_BACKENDS, BFD32_BACKENDS_CFILES): Remove PE PPC. * coffcode.h (coff_set_arch_mach_hook, coff_set_flags): Remove PPCMAGIC code. (coff_write_object_contents): Remove PPC_PE code. * config.bfd: Move powerpcle-pe to removed targets. * configure.ac: Remove powerpc PE entries. * libcoff-in.h (ppc_allocate_toc_section): Delete. (ppc_process_before_allocation): Delete. * peXXigen.c: Remove POWERPC_LE_PE code and comments. * targets.c: Remove powerpc PE vectors. * po/SRC-POTFILES.in: Regenerate. * libcoff.h: Regenerate. * Makefile.in: Regenerate. * configure: Regenerate. binutils/ * dlltool.c: Remove powerpc PE support and comments. * configure.ac: Remove powerpc PE dlltool config. * configure: Regenerate. gas/ * config/obj-coff.h: Remove TE_PE support. * config/tc-ppc.c: Likewise. * config/tc-ppc.h: Likewise. * configure.tgt: Remove powerpc PE and powerpc lynxos. * testsuite/gas/cfi/cfi.exp (cfi-common-6): Remove powerpc PE condition. * testsuite/gas/macros/macros.exp: Don't xfail powerpc PE. include/ * coff/powerpc.h: Delete. ld/ * emulparams/ppcpe.sh: Delete. * scripttempl/ppcpe.sc: Delete. * emulparams/ppclynx.sh: Delete. * Makefile.am (ALL_EMULATION_SOURCES): Remove ppc PE and lynxos. * configure.tgt: Likewise. * emultempl/beos.em: Remove powerpc PE support. * emultempl/pe.em: Likewise. * po/BLD-POTFILES.in: Regenerate. * Makefile.in: Regenerate.
Diffstat (limited to 'ld/emultempl/beos.em')
-rw-r--r--ld/emultempl/beos.em21
1 files changed, 1 insertions, 20 deletions
diff --git a/ld/emultempl/beos.em b/ld/emultempl/beos.em
index 4da5eeef6d2..ace6e3a123c 100644
--- a/ld/emultempl/beos.em
+++ b/ld/emultempl/beos.em
@@ -608,22 +608,6 @@ sort_sections (lang_statement_union_type *s)
static void
gld_${EMULATION_NAME}_before_allocation (void)
{
-#ifdef TARGET_IS_ppcpe
- /* Here we rummage through the found bfds to collect toc information */
- {
- LANG_FOR_EACH_INPUT_STATEMENT (is)
- {
- if (!ppc_process_before_allocation(is->the_bfd, &link_info))
- {
- einfo (_("%P: errors encountered processing file %s\n"),
- is->filename);
- }
- }
- }
-
- /* We have seen it all. Allocate it, and carry on */
- ppc_allocate_toc_section (&link_info);
-#else
#ifdef TARGET_IS_armpe
/* FIXME: we should be able to set the size of the interworking stub
section.
@@ -645,7 +629,6 @@ gld_${EMULATION_NAME}_before_allocation (void)
/* We have seen it all. Allocate it, and carry on */
arm_allocate_interworking_sections (& link_info);
#endif /* TARGET_IS_armpe */
-#endif /* TARGET_IS_ppcpe */
sort_sections (stat_ptr->head);
@@ -698,9 +681,7 @@ gld${EMULATION_NAME}_place_orphan (asection *s,
os = lang_output_section_statement_lookup (output_secname, constraint, TRUE);
/* Find the '\$' wild statement for this section. We currently require the
- linker script to explicitly mention "*(.foo\$)".
- FIXME: ppcpe.sc has .CRT\$foo in the .rdata section. According to the
- Microsoft docs this isn't correct so it's not (currently) handled. */
+ linker script to explicitly mention "*(.foo\$)". */
ps[0] = '\$';
ps[1] = 0;