summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bashinator/bashinator-0.3.1.ebuild')
-rw-r--r--app-shells/bashinator/bashinator-0.3.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-shells/bashinator/bashinator-0.3.1.ebuild b/app-shells/bashinator/bashinator-0.3.1.ebuild
new file mode 100644
index 0000000..b3533b2
--- /dev/null
+++ b/app-shells/bashinator/bashinator-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator
+
+DESCRIPTION="A bash shell script framework"
+HOMEPAGE="http://www.bashinator.org"
+
+SRC_URI="http://www.bashinator.org/releases/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="$(get_major_version)"
+
+KEYWORDS="amd64 x86"
+
+DEPEND=""
+RDEPEND="app-shells/bash
+ sys-apps/coreutils"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/lib
+ doins bashinator.lib.${SLOT}.sh
+ docinto example
+ PORTAGE_COMPRESS= dodoc example/*
+}