summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-04-23 18:53:14 +0000
committerRichard Brown <rbrown@gentoo.org>2007-04-23 18:53:14 +0000
commitf4301aeced8a5a445aff2fa0423bbe7d272ae232 (patch)
tree9f02045c0d79a020ad89d605bfa3c852cd3cadd2 /www-servers
parentAdd eclasses and sqlite-ruby (diff)
downloadrbrown-f4301aeced8a5a445aff2fa0423bbe7d272ae232.tar.gz
rbrown-f4301aeced8a5a445aff2fa0423bbe7d272ae232.tar.bz2
rbrown-f4301aeced8a5a445aff2fa0423bbe7d272ae232.zip
add ruby and gorg
svn path=/; revision=4
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gorg/gorg-0.6.3-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/gorg/gorg-0.6.3-r1.ebuild b/www-servers/gorg/gorg-0.6.3-r1.ebuild
new file mode 100644
index 0000000..0b6124b
--- /dev/null
+++ b/www-servers/gorg/gorg-0.6.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/gorg-0.6.3-r1.ebuild,v 1.1 2007/04/23 17:15:36 rbrown Exp $
+
+inherit ruby eutils
+
+DESCRIPTION="Back-end XSLT processor for an XML-based web site"
+HOMEPAGE="http://gentoo.neysx.org/mystuff/gorg/gorg.xml"
+SRC_URI="http://gentoo.neysx.org/mystuff/gorg/${P}.tgz"
+IUSE="apache fastcgi mysql"
+
+EAPI="paludis-1"
+SLOT="0"
+USE_RUBY="ruby18"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/ruby
+ >=dev-libs/libxml2-2.6.16
+ >=dev-libs/libxslt-1.1.12"
+RDEPEND="${DEPEND}
+ apache? ( net-www/apache )
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.5-r1
+ apache? ( >=www-apache/mod_fcgid-1.05 )
+ )
+ mysql? ( >=dev-ruby/ruby-dbi-0.0.21[mysql] >=dev-ruby/mysql-ruby-2.5 )"
+
+pkg_setup() {
+ enewgroup gorg
+ enewuser gorg -1 -1 -1 gorg
+}
+
+src_compile() {
+ # Fix listen issue w/ webrick
+ sed -i -e 's/WEBrick::HTTPServer.new(/WEBrick::HTTPServer.new( :BindAddress=>"127.0.0.1",/' lib/gorg/www.rb
+
+ ruby_src_compile
+}
+
+src_install() {
+ ruby_einstall
+
+ # install doesn't seem to chmod these correctly, forcing it here
+ SITE_LIB_DIR=`$RUBY -r rbconfig -e 'puts Config::CONFIG["sitelibdir"]'`
+ chmod +x ${D}/${SITE_LIB_DIR}/gorg/cgi-bin/*.cgi
+ chmod +x ${D}/${SITE_LIB_DIR}/gorg/fcgi-bin/*.fcgi
+
+ keepdir /etc/gorg; insinto /etc/gorg ; doins etc/gorg/*
+ diropts -m0770 -o gorg -g gorg; keepdir /var/cache/gorg
+
+ dodoc Changelog README
+}