summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/xtables-addons/files/xtables-addons-1.36-absolute-M.patch')
-rw-r--r--net-firewall/xtables-addons/files/xtables-addons-1.36-absolute-M.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-firewall/xtables-addons/files/xtables-addons-1.36-absolute-M.patch b/net-firewall/xtables-addons/files/xtables-addons-1.36-absolute-M.patch
new file mode 100644
index 0000000..e9513f0
--- /dev/null
+++ b/net-firewall/xtables-addons/files/xtables-addons-1.36-absolute-M.patch
@@ -0,0 +1,31 @@
+From 1493c53e2c3ade2c3ba1f4ec706b6d2860db73c2 Mon Sep 17 00:00:00 2001
+From: Peter Volkov <pva@gentoo.org>
+Date: Mon, 20 Jun 2011 10:50:29 +0400
+Subject: [PATCH] build: use absolute path for M=
+
+Use absolute path for M during checking kernelrelease. This will force
+temporary objects be built in the current directory and not $kbuilddir
+as it happened, e.g. in the current kernel scripts/Kbuild.include
+try-run target (it is called with TMPOUT=M=. and during call
+pwd=$kbuilddir). This should fix sandbox violation in Gentoo:
+https://bugs.gentoo.org/show_bug.cgi?id=371997
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0660eea..6361e48 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -42,7 +42,7 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
+
+ if test -n "$kbuilddir"; then
+ AC_MSG_CHECKING([kernel version that we will build against])
+- krel="$(make -sC "$kbuilddir" M=. kernelrelease)";
++ krel="$(make -sC "$kbuilddir" M="$(pwd)" kernelrelease)";
+ kmajor="${krel%%[[^0-9]]*}";
+ kmajor="$(($kmajor+0))";
+ krel="${krel:${#kmajor}}";
+--
+1.7.3.4
+