summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2012-07-11 14:43:17 -0400
committerMatthew Thode <prometheanfire@gentoo.org>2012-07-11 14:43:17 -0400
commitef0ab25f57ca42ed3f6a88b304fbc1a50017202d (patch)
treeb01acb4a56aa96e4111ceedc2c966db396533086 /net-analyzer
parentmanifest update (diff)
downloadprometheanfire-ef0ab25f57ca42ed3f6a88b304fbc1a50017202d.tar.gz
prometheanfire-ef0ab25f57ca42ed3f6a88b304fbc1a50017202d.tar.bz2
prometheanfire-ef0ab25f57ca42ed3f6a88b304fbc1a50017202d.zip
trying to make it work without forcing apache
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga-web/Manifest2
-rw-r--r--net-analyzer/icinga-web/icinga-web-1.7.1-r1.ebuild61
2 files changed, 49 insertions, 14 deletions
diff --git a/net-analyzer/icinga-web/Manifest b/net-analyzer/icinga-web/Manifest
index ce726b4..95b7912 100644
--- a/net-analyzer/icinga-web/Manifest
+++ b/net-analyzer/icinga-web/Manifest
@@ -2,5 +2,5 @@ AUX icinga-web-1.7.1-disable-compression.patch 3120 RMD160 0d73c244fa69debc37be8
DIST icinga-web-1.6.1.tar.gz 14735674 RMD160 106ab4b215e1adff53665ee43e25ea02d9715825 SHA1 58814f27f0e137b0dc5f56c3abdc223fa02958e4 SHA256 41c2d699355c6371447f551730e2dba80a0117f34f0608fa249e292904708ab4
DIST icinga-web-1.7.1.tar.gz 14551987 RMD160 2a61a47ec493c2424d0093b4154f7e0758c633f2 SHA1 70ae4f2c6915ebc814d82ac9d1d3d57ddb0e2a49 SHA256 6b585f243ae247c6ca018d4a9dc3dc976209f5c489166643c0863fa9189d55ef
EBUILD icinga-web-1.6.1-r1.ebuild 2292 RMD160 08005fc9e9fdd502e280f3b395c1764c1297d949 SHA1 ca36ffcc4013457099f0670b61746770f8c20335 SHA256 280bb7b6abd6523aa8ef413de6adb825c2d0ac809b06e4402883aaec45e0430a
-EBUILD icinga-web-1.7.1-r1.ebuild 3774 RMD160 da14977471eedd10ddf2daa51fffaf59ff0409b4 SHA1 010109dd1f9ebc5ec534dbac2e92f530df692492 SHA256 1ff7cc5d9d44106150b19214851b0386b916103208c990ede924564b6406c105
+EBUILD icinga-web-1.7.1-r1.ebuild 4609 RMD160 1bf979d5e6f4fac18a802dd83ec31290c4c1daed SHA1 e12afed3c25411f9b58775c0ab67a770258ac2a7 SHA256 4302a7bb6ba48c002a5cfcb142a60ee985e99520eda1fa61dd0f6f51ba7afc62
MISC ChangeLog 269 RMD160 50f58bfdece702df78994c9ca47add4a57ef3ae9 SHA1 7da37cb472aec84b463453c4360ffd5b157b19d5 SHA256 5b04c9b2c3510c6e759a3e16dc69304cf8b41cf093ec09a7d08bac9446da6df5
diff --git a/net-analyzer/icinga-web/icinga-web-1.7.1-r1.ebuild b/net-analyzer/icinga-web/icinga-web-1.7.1-r1.ebuild
index b91149e..77e3304 100644
--- a/net-analyzer/icinga-web/icinga-web-1.7.1-r1.ebuild
+++ b/net-analyzer/icinga-web/icinga-web-1.7.1-r1.ebuild
@@ -12,16 +12,19 @@ SRC_URI="mirror://sourceforge/icinga/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="pnp"
+IUSE="apache mysql pnp postgres"
DEPEND="dev-php/phing
- dev-lang/php[apache2,cli,mysql,pdo,json]
- net-analyzer/icinga[apache2,idoutils,mysql]"
+ dev-lang/php[apache2?,cli,mysql?,pdo,postgres?,json]
+ pnp? ( net-analyzer/pnp4nagios )"
RDEPEND="${DEPEND}"
need_apache2
pkg_setup() {
depend.apache_pkg_setup
+ enewgroup icinga
+ enewgroup nagios
+ enewuser icinga -1 -1 /var/lib/icinga "icinga,nagios"
}
src_prepare() {
@@ -39,14 +42,24 @@ src_configure() {
--sysconfdir=/etc/icinga
--libexecdir=/usr/$(get_libdir)/icinga/plugins
--with-bin-user=icinga
- --with-bin-group=icinga
- --with-web-user=apache
- --with-web-group=apache
- --with-web-apache-path=${APACHE_MODULES_CONFDIR}
+ --with-bin-group=nagios
--with-api-cmd-file=/var/lib/icinga/rw/icinga.cmd
--with-conf-dir=/etc/icinga-web
--with-log-dir=/var/log/icinga-web"
+ if use apache ; then
+ myconf+=" --with-web-user=apache
+ --with-web-group=apache
+ --with-web-apache-path=${APACHE_MODULES_CONFDIR}"
+ else
+ myconf+=" --with-web-user=root
+ --with-web-group=root"
+ fi
+
+ if use postgres ; then
+ myconf+=" --with-db-type=postgres"
+ fi
+
econf ${myconf}
}
@@ -55,23 +68,38 @@ src_install() {
emake -j1 DESTDIR="${D}" install-javascript || die "make failed"
- dodir ${APACHE_MODULES_CONFDIR}
- emake -j1 DESTDIR="${D}" install-apache-config || die "make failed"
- mv ${D}/${APACHE_MODULES_CONFDIR}/icinga-web.conf ${D}/${APACHE_MODULES_CONFDIR}/99_icinga-web.conf
+ if use apache ; then
+ dodir ${APACHE_MODULES_CONFDIR}
+ emake -j1 DESTDIR="${D}" install-apache-config || die "make failed"
+ mv ${D}/${APACHE_MODULES_CONFDIR}/icinga-web.conf ${D}/${APACHE_MODULES_CONFDIR}/99_icinga-web.conf
+ fi
insinto /usr/share/icinga/icinga-web/contrib
doins -r etc/schema/* || die
- sed -i 's/%%USER%%/apache/g' etc/scheduler/icingaCron
+ if use apache ; then
+ sed -i 's/%%USER%%/apache/g' etc/scheduler/icingaCron
+ else
+ sed -i 's/%%USER%%/root/g' etc/scheduler/icingaCron
+ fi
sed -i 's/%%PATH%%/\/usr\/share\/icinga\/icinga-web/g' etc/scheduler/icingaCron
insinto /etc/cron.d/
doins etc/scheduler/icingaCron || die
- diropts -o apache -g apache
+ if use apache ; then
+ diropts -o apache -g apache
+ else
+ diropts -o root -g root
+ fi
dodir /var/log/icinga-web
- fowners apache:apache /usr/share/icinga/icinga-web/lib/icingaScheduler/res/storage.dat
+ if use apache ; then
+ fowners apache:apache /usr/share/icinga/icinga-web/lib/icingaScheduler/res/storage.dat
+ else
+ fowners root:root /usr/share/icinga/icinga-web/lib/icingaScheduler/res/storage.dat
+ fi
+
if use pnp ; then
insinto /usr/share/icinga/icinga-web/app/modules/Cronks/data/xml/extensions/
@@ -113,5 +141,12 @@ pkg_postinst() {
einfo
einfo "Please note that the magic_quotes_gpc setting must be disabled (in both apache and cli php.ini)."
einfo
+
+ if use apache ; then
+ einfo
+ einfo "The apache config value for \'ServerTokens\' must be set to at"
+ einfo "least \'Min\'."
+ einfo
+ fi
}