summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2012-10-26 15:35:07 -0500
committerMatthew Thode <mthode@mthode.org>2012-10-26 15:35:07 -0500
commit8338fdecf0bc0a3305b95bc69ca07028e432d9b8 (patch)
tree12acd4ce0344188ad4f2ec95ee8e294bf123477f /dev-python/python-quantumclient
parentremoved skype and selinux-nslcd (diff)
downloadprometheanfire-8338fdecf0bc0a3305b95bc69ca07028e432d9b8.tar.gz
prometheanfire-8338fdecf0bc0a3305b95bc69ca07028e432d9b8.tar.bz2
prometheanfire-8338fdecf0bc0a3305b95bc69ca07028e432d9b8.zip
adding first try of openstack
Diffstat (limited to 'dev-python/python-quantumclient')
-rw-r--r--dev-python/python-quantumclient/Manifest1
-rw-r--r--dev-python/python-quantumclient/python-quantumclient-9999.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-quantumclient/Manifest b/dev-python/python-quantumclient/Manifest
new file mode 100644
index 0000000..ab9bca1
--- /dev/null
+++ b/dev-python/python-quantumclient/Manifest
@@ -0,0 +1 @@
+EBUILD python-quantumclient-9999.ebuild 652 RMD160 e8f902fce5a484215afa7a609fca435928bcff81 SHA1 b26feee2ea67e97a25f46164f0ee2811ab07b955 SHA256 2d5ccf8242d6ff88bf41f61e572b2a8f32a2a32a434a81e803fa093d66784162
diff --git a/dev-python/python-quantumclient/python-quantumclient-9999.ebuild b/dev-python/python-quantumclient/python-quantumclient-9999.ebuild
new file mode 100644
index 0000000..6b10104
--- /dev/null
+++ b/dev-python/python-quantumclient/python-quantumclient-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit git-2 distutils
+
+DESCRIPTION="This is the client API library for Quantum."
+HOMEPAGE="http://wiki.openstack.org/Quantum"
+EGIT_REPO_URI="https://github.com/openstack/python-quantumclient.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/pep8
+ dev-python/nosexcover
+ dev-python/nose
+ dev-python/coverage
+ dev-python/paste
+ dev-python/pastedeploy
+ dev-python/python-gflags
+ dev-python/webob
+ net-misc/quantum"
+RDEPEND="${DEPEND}"