summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 22:08:12 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 22:08:12 +0000
commit980528bd9533febffe1c0de6a97d87297aa4ebd9 (patch)
tree766226ad8073ea251a7ebf962790306869a9a8f2
parentClean up src_unpack. (diff)
downloadomp-980528bd9533febffe1c0de6a97d87297aa4ebd9.tar.gz
omp-980528bd9533febffe1c0de6a97d87297aa4ebd9.tar.bz2
omp-980528bd9533febffe1c0de6a97d87297aa4ebd9.zip
Organise econf command; add messages to die statements.
svn path=/; revision=5
-rw-r--r--x11-wm/fvwm/fvwm-2.5.25.ebuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/x11-wm/fvwm/fvwm-2.5.25.ebuild b/x11-wm/fvwm/fvwm-2.5.25.ebuild
index a8f47ee..6f9a73c 100644
--- a/x11-wm/fvwm/fvwm-2.5.25.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.25.ebuild
@@ -90,25 +90,28 @@ src_compile() {
append-flags -fsigned-char
fi
- econf ${myconf} `use_enable truetype xft` \
- `use_with stroke stroke-library` \
- `use_enable nls` \
- `use_enable nls iconv` \
- `use_with png png-library` \
- `use_enable bidi` \
- `use_enable xinerama` \
- `use_enable debug debug-msgs` \
- `use_enable debug command-log` \
- `use_enable perl perllib` \
- `use_with readline readline-library` \
- `use_enable svg rsvg` \
- `use_enable doc htmldoc` \
- `use_with rplay rplay-library` || die
- emake || die
+ econf ${myconf} \
+ $(use_enable bidi) \
+ $(use_enable debug debug-msgs) \
+ $(use_enable debug command-log) \
+ $(use_enable doc htmldoc) \
+ $(use_enable nls) \
+ $(use_enable nls iconv) \
+ $(use_enable perl perllib) \
+ $(use_with png png-library) \
+ $(use_with readline readline-library) \
+ $(use_with rplay rplay-library) \
+ $(use_with stroke stroke-library) \
+ $(use_enable svg rsvg) \
+ $(use_enable truetype xft) \
+ $(use_enable xinerama) \
+ || die "econf failed"
+
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
if use perl; then