summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 22:19:50 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 22:19:50 +0000
commit4d84dcd39332c5b706627e98100ffe2504d9a06e (patch)
treea825872e69fa958dd977113e91a42796a65377d8
parentDo not dodoc README.translucency if vanilla flag is enabled. (diff)
downloadomp-4d84dcd39332c5b706627e98100ffe2504d9a06e.tar.gz
omp-4d84dcd39332c5b706627e98100ffe2504d9a06e.tar.bz2
omp-4d84dcd39332c5b706627e98100ffe2504d9a06e.zip
Add missing quotes; shorten rm command.
svn path=/; revision=8
-rw-r--r--x11-wm/fvwm/fvwm-2.5.25.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11-wm/fvwm/fvwm-2.5.25.ebuild b/x11-wm/fvwm/fvwm-2.5.25.ebuild
index 033fbfc..6617ecb 100644
--- a/x11-wm/fvwm/fvwm-2.5.25.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.25.ebuild
@@ -111,7 +111,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
if use perl; then
@@ -119,36 +119,35 @@ src_install() {
if ! use tk; then
# Remove the Tk bindings (requires perl-tk)
- rm -f ${D}/usr/share/fvwm/perllib/FVWM/Module/Tk.pm
+ rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Tk.pm"
toolkits=${toolkits/tcltk/}
fi
if ! use gtk; then
# Remove gtk bindings (requires gtk-perl/gtk2-perl)
- rm -f ${D}/usr/share/fvwm/perllib/FVWM/Module/Gtk.pm \
- ${D}/usr/share/fvwm/perllib/FVWM/Module/Gtk2.pm
+ rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/"Gtk{,2}.pm
toolkits=${toolkits/gtk/}
fi
toolkits=${toolkits// /}
if ! test "${toolkits}"; then
# No perl toolkit bindings wanted, remove the unneeded files
# and empty directories.
- rm -f ${D}/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm
- find ${D}/usr/share/fvwm/perllib -depth -type d -exec rmdir {} \; 2>/dev/null
+ rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm"
+ find "${D}/usr/share/fvwm/perllib" -depth -type d -exec rmdir {} \; 2>/dev/null
fi
else
# Remove useless script if perllib isnt required.
- rm -rf ${D}/usr/bin/fvwm-perllib ${D}/usr/share/man/man1/fvwm-perllib.1
+ rm -rf "${D}/usr/bin/fvwm-perllib" "${D}/usr/share/man/man1/fvwm-perllib.1"
fi
# neat utility for testing fvwm behaviour on applications setting various
# hints, creates a simple black window with configurable hints set.
if use debug; then
- dobin ${S}/tests/hints/hints_test
- newdoc ${S}/tests/hints/README README.hints
+ dobin "${S}/tests/hints/hints_test"
+ newdoc "${S}/tests/hints/README" README.hints
fi
# fvwm-convert-2.6 is just a stub, contains no code - remove it for now.
- rm -f ${D}/usr/bin/fvwm-convert-2.6 ${D}/usr/share/man/man1/fvwm-convert-2.6.1
+ rm -f "${D}/usr/bin/fvwm-convert-2.6" "${D}/usr/share/man/man1/fvwm-convert-2.6.1"
# ive included `exec` to save a few bytes of memory.
echo "#!/bin/bash" > fvwm2