summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2007-01-22 18:48:30 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2007-01-22 18:48:30 +0000
commit67b48e11d7b4f877378f9a1fd65900e11ca9f3ff (patch)
tree874c2844eca7d820b2b5c35ada6cdd2c051c99ca
parentNew pieworld - everything that isn't fPIC is fPIE. (diff)
downloadkevquinn-67b48e11d7b4f877378f9a1fd65900e11ca9f3ff.tar.gz
kevquinn-67b48e11d7b4f877378f9a1fd65900e11ca9f3ff.tar.bz2
kevquinn-67b48e11d7b4f877378f9a1fd65900e11ca9f3ff.zip
Remove defunct file
svn path=/; revision=151
-rw-r--r--hardened/toolchain/branches/pieworld/sys-libs/glibc/files/2.4/glibc-2.4-linuxssp.patch129
1 files changed, 0 insertions, 129 deletions
diff --git a/hardened/toolchain/branches/pieworld/sys-libs/glibc/files/2.4/glibc-2.4-linuxssp.patch b/hardened/toolchain/branches/pieworld/sys-libs/glibc/files/2.4/glibc-2.4-linuxssp.patch
deleted file mode 100644
index 9be5201..0000000
--- a/hardened/toolchain/branches/pieworld/sys-libs/glibc/files/2.4/glibc-2.4-linuxssp.patch
+++ /dev/null
@@ -1,129 +0,0 @@
- Modifications to glibc-2.4 to allow it to build with stack-protection
- enabled throughout.
-
- debug/Makefile: build stack_chk_fail_local -fno-stack-protector
- Leave stack_chk_fail alone, so checking __SSP__ will show whether
- compiler is rigged to build SSP, and hence that we want the modified
- handler (which will never trigger SSP because there are no function
- calls).
-
- csu/Makefile, linuxthreads/Makefile, nptl/Makefile: inihibit SSP on
- crti/crtn (i.e. compilation of initfini)
-
- elf/rtld-Rules: Add compilation rules for .oS targets (so that
- stack_chk_fail_local will build for rtld).
-
- elf/Makefile: Add libc_nonshared.a to rtld build set so that
- stack_chk_fail_local can be found (and other modifications
- so that static objects are considered).
-
- Makerules: add stack_chk_fail_local.oS to libc_pic.os (needed for
- SSP builds on x86 so that it can resolve __stack_chk_fail_local).
- Note this is a whole-archive link so adding libc_nonshared.a
- causes too much stuff to be included.
-
- Kevin F. Quinn 2006-09-30
-
---- debug/Makefile.orig 2006-09-30 17:06:31.000000000 +0200
-+++ debug/Makefile 2006-09-30 17:12:45.000000000 +0200
-@@ -70,6 +71,7 @@
- CFLAGS-pread64_chk.c = -fexceptions -fasynchronous-unwind-tables
- CFLAGS-recv_chk.c = -fexceptions -fasynchronous-unwind-tables
- CFLAGS-recvfrom_chk.c = -fexceptions -fasynchronous-unwind-tables
-+CFLAGS-stack_chk_fail_local.c = -fno-stack-protector
-
- tst-chk1-ENV = LOCPATH=$(common-objpfx)localedata
- tst-chk2-ENV = LOCPATH=$(common-objpfx)localedata
---- csu/Makefile.orig 2006-09-30 13:22:19.000000000 +0200
-+++ csu/Makefile 2006-09-30 13:22:38.000000000 +0200
-@@ -93,7 +93,7 @@
- $(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
- $(compile.S) -g0 $(ASFLAGS-.os) -o $@
-
--CFLAGS-initfini.s = -g0 -fPIC -fno-inline-functions $(fno-unit-at-a-time)
-+CFLAGS-initfini.s = -g0 -fPIC -fno-inline-functions -fno-stack-protector $(fno-unit-at-a-time)
-
- vpath initfini.c $(sysdirs)
-
---- linuxthreads/Makefile.orig 2006-09-30 14:39:33.000000000 +0200
-+++ linuxthreads/Makefile 2006-09-30 14:39:42.000000000 +0200
-@@ -102,7 +102,7 @@
- extra-objs += $(crti-objs) $(crtn-objs)
- omit-deps += crti crtn
-
--CFLAGS-pt-initfini.s = -g0 -fPIC -fno-inline-functions $(fno-unit-at-a-time)
-+CFLAGS-pt-initfini.s = -g0 -fPIC -fno-stack-protector -fno-inline-functions $(fno-unit-at-a-time)
- endif
-
- librt-tests = ex10 ex11 tst-clock1
---- nptl/Makefile.orig 2006-09-30 14:36:46.000000000 +0200
-+++ nptl/Makefile 2006-09-30 14:37:06.000000000 +0200
-@@ -335,7 +335,7 @@
- extra-objs += $(crti-objs) $(crtn-objs)
- omit-deps += crti crtn
-
--CFLAGS-pt-initfini.s = -g0 -fPIC -fno-inline-functions $(fno-unit-at-a-time)
-+CFLAGS-pt-initfini.s = -g0 -fPIC -fno-stack-protector -fno-inline-functions $(fno-unit-at-a-time)
- endif
-
- CFLAGS-flockfile.c = -D_IO_MTSAFE_IO
---- elf/Makefile.orig 2006-10-01 01:37:29.000000000 +0200
-+++ elf/Makefile 2006-10-01 01:44:19.000000000 +0200
-@@ -263,7 +263,7 @@
- # are compiled with special flags, and puts these modules into rtld-libc.a
- # for us. Then we do the real link using rtld-libc.a instead of libc_pic.a.
-
--$(objpfx)librtld.map: $(objpfx)dl-allobjs.os $(common-objpfx)libc_pic.a
-+$(objpfx)librtld.map: $(objpfx)dl-allobjs.os $(common-objpfx)libc_pic.a $(common-objpfx)libc_nonshared.a
- @-rm -f $@T
- $(reloc-link) -o $@.o '-Wl,-(' $^ -lgcc '-Wl,-)' -Wl,-Map,$@T
- rm -f $@.o
-@@ -271,7 +271,7 @@
-
- $(objpfx)librtld.mk: $(objpfx)librtld.map Makefile
- LC_ALL=C \
-- sed -n 's@^$(common-objpfx)\([^(]*\)(\([^)]*\.os\)) *.*$$@\1 \2@p' \
-+ sed -n 's@^$(common-objpfx)\([^(]*\)(\([^)]*\.o[Ss]\)) *.*$$@\1 \2@p' \
- $< | \
- while read lib file; do \
- case $$lib in \
-@@ -281,6 +281,12 @@
- LC_ALL=C \
- sed 's@^$(common-objpfx)\([^/]*\)/stamp\.os$$@rtld-\1'" +=$$file@"\
- ;; \
-+ libc_nonshared.a) \
-+ LC_ALL=C fgrep -l /$$file \
-+ $(common-objpfx)stamp.oS $(common-objpfx)*/stamp.oS | \
-+ LC_ALL=C \
-+ sed 's@^$(common-objpfx)\([^/]*\)/stamp\.oS$$@rtld-\1'" +=$$file@"\
-+ ;; \
- */*.a) \
- echo rtld-$${lib%%/*} += $$file ;; \
- *) echo "Wasn't expecting $$lib($$file)" >&2; exit 1 ;; \
---- elf/rtld-Rules.orig 2006-10-01 01:41:07.000000000 +0200
-+++ elf/rtld-Rules 2006-10-01 01:41:40.000000000 +0200
-@@ -96,11 +96,13 @@
- $(objpfx)rtld-%.os: %.S $(before-compile); $(compile-command.S)
- $(objpfx)rtld-%.os: %.s $(before-compile); $(compile-command.s)
- $(objpfx)rtld-%.os: %.c $(before-compile); $(compile-command.c)
-+$(objpfx)rtld-%.oS: %.c $(before-compile); $(compile-command.c)
-
- # The rules for generated source files.
- $(objpfx)rtld-%.os: $(objpfx)%.S $(before-compile); $(compile-command.S)
- $(objpfx)rtld-%.os: $(objpfx)%.s $(before-compile); $(compile-command.s)
- $(objpfx)rtld-%.os: $(objpfx)%.c $(before-compile); $(compile-command.c)
-+$(objpfx)rtld-%.oS: $(objpfx)%.c $(before-compile); $(compile-command.c)
-
- # The command line setting of rtld-modules (see above) tells us
- # what we need to build, and that tells us what dependency files we need.
---- Makerules.orig 2006-10-01 11:26:40.000000000 +0200
-+++ Makerules 2006-10-01 11:27:30.000000000 +0200
-@@ -602,7 +602,7 @@
- # from being allocated in libc.so, which introduces evil dependencies
- # between libc.so and ld.so, which can make it impossible to upgrade.
- ifeq ($(elf),yes)
--$(common-objpfx)libc_pic.os: $(common-objpfx)libc_pic.a
-+$(common-objpfx)libc_pic.os: $(common-objpfx)libc_pic.a $(common-objpfx)debug/stack_chk_fail_local.oS
- $(LINK.o) -nostdlib -nostartfiles -r -o $@ \
- $(LDFLAGS-c_pic.os) -Wl,-d -Wl,--whole-archive $^
- # Use our own special initializer and finalizer files for libc.so.