summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-12-17 10:49:24 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-12-17 10:49:24 +0000
commit0d64721be6f49941a4cf687054b8527b02f6639d (patch)
tree2c9691ff19302e2b11be58d0394609b068f80f41
parentBuild crt{begin,end}.o -fno-PIE (diff)
downloadkevquinn-0d64721be6f49941a4cf687054b8527b02f6639d.tar.gz
kevquinn-0d64721be6f49941a4cf687054b8527b02f6639d.tar.bz2
kevquinn-0d64721be6f49941a4cf687054b8527b02f6639d.zip
Get crt{begin,end}.o building properly for all linux
svn path=/; revision=114
-rw-r--r--hardened/toolchain/eclass/toolchain.eclass7
1 files changed, 4 insertions, 3 deletions
diff --git a/hardened/toolchain/eclass/toolchain.eclass b/hardened/toolchain/eclass/toolchain.eclass
index 2b0ceaf..20fbd1c 100644
--- a/hardened/toolchain/eclass/toolchain.eclass
+++ b/hardened/toolchain/eclass/toolchain.eclass
@@ -2157,9 +2157,10 @@ do_gcc_PIE_patches() {
# adds non-default pie support (rs6000)
EPATCH_MULTI_MSG="Applying non-default pie patches ..." \
epatch "${WORKDIR}"/piepatch/nondef
- # Force crt{begin,end}.o to be built normally
- sed -e 's/^CRTSTUFF_T_CFLAGS =/CRTSTUFF_T_CFLAGS = -fno-PIE/' \
- -i "${S}"/gcc/Makefile.in
+ # Force crt{begin,end}.o to be built normally; for all linux
+ # If Gentoo/FreeBSD ever want hardened, need to do the same to t-freebsd
+ sed -e '/^CRTSTUFF_T_CFLAGS_S =/iCRTSTUFF_T_CFLAGS = $(CRTSTUFF_T_CFLAGS) -fno-PIE' \
+ -i "${S}"/gcc/config/t-linux
# adds default pie support (rs6000 too) if DEFAULT_PIE[_SSP] is defined
want_minispecs ||
EPATCH_MULTI_MSG="Applying default pie patches ..." \