summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dialup/vodafone-mobile-connect/vodafone-mobile-connect-2.0_beta3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-dialup/vodafone-mobile-connect/vodafone-mobile-connect-2.0_beta3.ebuild b/net-dialup/vodafone-mobile-connect/vodafone-mobile-connect-2.0_beta3.ebuild
new file mode 100644
index 0000000..beaa7fe
--- /dev/null
+++ b/net-dialup/vodafone-mobile-connect/vodafone-mobile-connect-2.0_beta3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit distutils
+
+MY_PN=vodafone-mobile-connect-card-driver-for-linux
+MY_PV=${PV/_beta/.beta}
+MY_P=${MY_PN}-${MY_PV}
+DESCRIPTION="GUI for Vodafone and other UMTS/HSDPA Sticks and Cards"
+HOMEPAGE="https://forge.betavine.net/projects/vodafonemobilec/"
+# URI has absolute addressing, so specifying in full, listing
+# at https://forge.betavine.net/frs/?group_id=12
+SRC_URI="https://forge.betavine.net/frs/download.php/267/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/twisted
+ dev-python/pyserial
+ dev-python/pygtk:2
+ >=dev-lang/python-2.5[sqlite]
+ net-dialup/wvdial
+ dev-python/notify-python
+ dev-python/gnome-python
+ dev-python/pytz
+ >=sys-apps/usb_modeswitch-0.9.6"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}