aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/quassel/files/quasselcore.service11
-rw-r--r--net-irc/quassel/quassel-9999.ebuild5
2 files changed, 14 insertions, 2 deletions
diff --git a/net-irc/quassel/files/quasselcore.service b/net-irc/quassel/files/quasselcore.service
new file mode 100644
index 0000000..f5b49ab
--- /dev/null
+++ b/net-irc/quassel/files/quasselcore.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Quassel Core
+After=network.target
+
+[Service]
+User=quassel
+Group=quassel
+ExecStart=/usr/bin/quasselcore --configdir=/var/lib/quassel
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index 006e4d4..f2f17d6 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit cmake-utils eutils pax-utils user versionator
+inherit cmake-utils eutils pax-utils systemd user versionator
EGIT_REPO_URI="git://git.quassel-irc.org/quassel"
[[ "${PV}" == "9999" ]] && inherit git-r3
@@ -143,9 +143,10 @@ src_install() {
keepdir "${QUASSEL_DIR}"
fowners "${QUASSEL_USER}":"${QUASSEL_USER}" "${QUASSEL_DIR}"
- # init scripts
+ # init scripts & systemd unit
newinitd "${FILESDIR}"/quasselcore.init quasselcore
newconfd "${FILESDIR}"/quasselcore.conf quasselcore
+ systemd_dounit "${FILESDIR}"/quasselcore.service
# logrotate
insinto /etc/logrotate.d