summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
committerBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
commitfb26a5c2df5e1fde31491ebeff69112712008353 (patch)
tree2f8414516404877c9df8e29df0c2b2536ab2bd5c /sci-physics
downloadheroxbd-fb26a5c2df5e1fde31491ebeff69112712008353.tar.gz
heroxbd-fb26a5c2df5e1fde31491ebeff69112712008353.tar.bz2
heroxbd-fb26a5c2df5e1fde31491ebeff69112712008353.zip
initial commit
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/g4py/Manifest4
-rw-r--r--sci-physics/g4py/files/g4py-4.9.5-build.patch39
-rw-r--r--sci-physics/g4py/files/g4py-4.9.5-visverbose.patch13
-rw-r--r--sci-physics/g4py/g4py-4.9.5.ebuild75
-rw-r--r--sci-physics/geant/ChangeLog290
-rw-r--r--sci-physics/geant/Manifest6
-rw-r--r--sci-physics/geant/files/geant-4.9.4-zlib.patch34
-rw-r--r--sci-physics/geant/files/geant-4.9.5-scripts-only-dataenv.patch55
-rw-r--r--sci-physics/geant/geant-4.9.5-r1.ebuild85
-rw-r--r--sci-physics/geant/metadata.xml31
10 files changed, 632 insertions, 0 deletions
diff --git a/sci-physics/g4py/Manifest b/sci-physics/g4py/Manifest
new file mode 100644
index 0000000..3b3dffa
--- /dev/null
+++ b/sci-physics/g4py/Manifest
@@ -0,0 +1,4 @@
+AUX g4py-4.9.5-build.patch 958 RMD160 5aef44b3dc2774da7e39e6ff18d018635cdee536 SHA1 419c3c9218094f40bcbc81e2b2e4bbf4cae4b30f SHA256 d6217f5537e89bf849b7e1d1b79670fb2a759dfebc7a488d768d02181c9ddf9e
+AUX g4py-4.9.5-visverbose.patch 557 RMD160 752266b165007dc61dfe3e6e21804dca63c59754 SHA1 e2691a1bd095741de558e61771b9b8992c77a2fb SHA256 0955cd39ce1f8e842e2804370359a4e367b14f4791a40fd653918c32884bed8a
+DIST geant4.9.5.tar.gz 28458437 RMD160 24e78b5243aa9ec47a48bbcb6d2afb4d9fe22dbf SHA1 846b48e82c1709d77a8f490fd12b039acc1d0cf9 SHA256 b6b31752319805052fb765f89ca38a23fb299a0a5bf900daeacd1950d6c9a597
+EBUILD g4py-4.9.5.ebuild 2184 RMD160 7619e8f6ac637742c36632f5e614cea3a39dcb2f SHA1 8d2a66b677913d15b696a0587ea54d0636f2de92 SHA256 c08d0d261806af91f38bbda9e68496ad722f07d682303ea67dedb6899e1aa4ff
diff --git a/sci-physics/g4py/files/g4py-4.9.5-build.patch b/sci-physics/g4py/files/g4py-4.9.5-build.patch
new file mode 100644
index 0000000..d163d00
--- /dev/null
+++ b/sci-physics/g4py/files/g4py-4.9.5-build.patch
@@ -0,0 +1,39 @@
+1. make configure respect --with-python-incdir
+
+diff --git a/configure b/configure
+index 2d755b1..3db111f 100755
+--- a/configure
++++ b/configure
+@@ -330,18 +330,21 @@ echo "lib${clhep_lib}.${shlib}"
+ # ---
+ echo $ac_n "Checking for Python include dir (pyconfig.h) ... $ac_c"
+ # check version
+-if [ $with_python3 = 0 ]; then
+- set python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2
+-else
+- set python3.1 python3.0
++if [ ! -d "$python_incdir" ]
++then
++ if [ $with_python3 = 0 ]; then
++ set python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2
++ else
++ set python3.1 python3.0
++ fi
++ for aincdir in $*
++ do
++ if [ -d /usr/include/"$aincdir" ]; then
++ python_incdir=/usr/include/$aincdir
++ break
++ fi
++ done
+ fi
+-for aincdir in $*
+-do
+- if [ -d /usr/include/"$aincdir" ]; then
+- python_incdir=/usr/include/$aincdir
+- break
+- fi
+-done
+
+ if [ ! -f "$python_incdir"/pyconfig.h ]; then
+ echo "no"
diff --git a/sci-physics/g4py/files/g4py-4.9.5-visverbose.patch b/sci-physics/g4py/files/g4py-4.9.5-visverbose.patch
new file mode 100644
index 0000000..0508f28
--- /dev/null
+++ b/sci-physics/g4py/files/g4py-4.9.5-visverbose.patch
@@ -0,0 +1,13 @@
+diff --git a/source/visualization/pyG4VisManager.cc b/source/visualization/pyG4VisManager.cc
+index 33bb0d4..00f86a5 100644
+--- a/source/visualization/pyG4VisManager.cc
++++ b/source/visualization/pyG4VisManager.cc
+@@ -41,7 +41,7 @@ using namespace boost::python;
+ // ====================================================================
+ class PyG4VisManager : public G4VisManager {
+ public:
+- PyG4VisManager() { SetVerboseLevel(quiet); }
++ PyG4VisManager() { SetVerboseLevel(all); }
+ ~PyG4VisManager() { }
+
+ virtual void RegisterGraphicsSystems() { }
diff --git a/sci-physics/g4py/g4py-4.9.5.ebuild b/sci-physics/g4py/g4py-4.9.5.ebuild
new file mode 100644
index 0000000..c4c11bf
--- /dev/null
+++ b/sci-physics/g4py/g4py-4.9.5.ebuild
@@ -0,0 +1,75 @@
+EAPI=4
+
+inherit python versionator
+
+MYP="geant$(replace_version_separator 3 .)"
+
+DESCRIPTION="Python binding for geant"
+HOMEPAGE="http://geant4.cern.ch/"
+SRC_URI="http://geant4.cern.ch/support/source/${MYP}.tar.gz"
+KEYWORDS="~amd64-linux ~x86-linux"
+
+LICENSE="geant4"
+SLOT="0"
+
+RDEPEND="sci-physics/geant:4 \
+ dev-libs/boost[python]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}/environments/g4py"
+
+src_prepare() {
+ # DISTDIR and python path patch
+ epatch "${FILESDIR}"/${PN}-4.9.5-build.patch
+
+ # set to the highest verbose for visManager
+ epatch "${FILESDIR}"/${PN}-4.9.5-visverbose.patch
+
+ # let Geant4 module installed into python sitedir instead of default
+ sed -i "/G4PY_LIBDIR :=/cG4PY_LIBDIR := $\(DESTDIR\)$(python_get_sitedir)/Geant4" \
+ config/install.gmk || die "sed failed on config/install.gmk"
+ for mfile in source/python{3,}/GNUmakefile
+ do
+ sed -i "/install_dir :=/cinstall_dir := $\(DESTDIR\)$(python_get_sitedir)/Geant4" \
+ "${mfile}" || die "sed failed on ${mfile}"
+ done
+
+ # let g4py module installed into python sitedir instead of default
+ sed -i "/install_dir :=/cinstall_dir := $\(DESTDIR\)$(python_get_sitedir)/${PN}" \
+ config/site-install.gmk || die "sed failed on config/site-install.gmk"
+ for mfile in {processes/emcalculator,utils/MCScore}/{python3/,}GNUmakefile python/GNUmakefile
+ do
+ sed -i "/install_dir :=/cinstall_dir := $\(DESTDIR\)$(python_get_sitedir)/${PN}" \
+ "site-modules/${mfile}" || die "sed failed on site-modules/${mfile}"
+ done
+}
+
+src_configure() {
+ case ${CHOST} in
+ x86_64-pc-linux-gnu)
+ ARG=linux64
+ ;;
+ i?86-pc-linux-gnu)
+ ARG=linux
+ ;;
+ *)
+ die "platform unknown"
+ ;;
+ esac
+
+ ./configure ${ARG} \
+ --prefix="${EPREFIX}/usr" \
+ --with-g4-incdir="${EPREFIX}/usr/include/Geant4" \
+ --with-g4-libdir="${EPREFIX}/usr/lib" \
+ --with-clhep-incdir="${EPREFIX}/usr/include" \
+ --with-clhep-libdir="${EPREFIX}/usr/lib" \
+ --with-python-incdir="${EPREFIX}$(python_get_includedir)" \
+ --with-python-libdir="${EPREFIX}$(python_get_libdir)" \
+ --with-boost-incdir="${EPREFIX}/usr/include" \
+ --with-boost-libdir="${EPREFIX}/usr/lib" \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+}
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
new file mode 100644
index 0000000..79e2e3c
--- /dev/null
+++ b/sci-physics/geant/ChangeLog
@@ -0,0 +1,290 @@
+# ChangeLog for sci-physics/geant
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.56 2012/03/13 21:52:56 bicatali Exp $
+
+*geant-4.9.5-r1 (13 Mar 2012)
+
+ 13 Mar 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ files/geant-4.9.4-zlib.patch, +geant-4.9.5-r1.ebuild:
+ Fixed more zlib issues. The geant3 flag is now only for unit conversion (if
+ geant3 is needed, geant:3 has to be installed from user). The data is now
+ fetched (building needs network) to ease maintenance and set up the proper
+ env variables in the geant4*sh scripts. Removed a use dawn duplicate. Thanks
+ Marek Szuba for his suggestions (bug #407517 and bug #359673). Added a
+ message for backward compatibility (bug #360285)
+
+*geant-4.9.5 (18 Dec 2011)
+*geant-4.9.4_p03 (18 Dec 2011)
+
+ 18 Dec 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ -geant-4.9.3_p02-r1.ebuild, -geant-4.9.4_p01.ebuild, +geant-4.9.4_p03.ebuild,
+ +files/geant-4.9.4-trajectory.patch, files/geant-4.9.4-zlib.patch,
+ +geant-4.9.5.ebuild:
+ Version bumps. Re-introduced some older flags and fixed linking of
+ zlib. Added patch for source trajectory example (bug #365171), thanks Matthias Nagl.
+
+ 02 Aug 2011; Matt Turner <mattst88@gentoo.org> geant-4.9.2_p02.ebuild,
+ geant-4.9.3_p02-r1.ebuild:
+ Renamed x11-libs/Xaw3d to x11-libs/libXaw3d.
+
+*geant-3.21.14-r3 (21 Jul 2011)
+
+ 21 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-3.21.14-r3.ebuild:
+ New debian patch set. Switch to EAPI4
+
+ 28 Jun 2011; Justin Lecher <jlec@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild, geant-4.9.3_p02-r1.ebuild, geant-4.9.4_p01.ebuild,
+ metadata.xml:
+ Fix sed on *FLAGS from : to |, EAPI bump
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild, geant-4.9.3_p02-r1.ebuild, geant-4.9.4_p01.ebuild:
+ Add dependency on virtual/fortran
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild, geant-4.9.3_p02-r1.ebuild, geant-4.9.4_p01.ebuild:
+ Added fortran-2.eclass support
+
+ 07 Jun 2011; Jeroen Roovers <jer@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild, geant-4.9.3_p02-r1.ebuild, geant-4.9.4_p01.ebuild:
+ Drop HPPA keywording.
+
+ 22 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> geant-4.9.4_p01.ebuild:
+ Proper CMake optional use bug #359437 thanks Rafal Lalik
+
+*geant-4.9.4_p01 (18 Mar 2011)
+
+ 18 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> -geant-4.9.4.ebuild,
+ +geant-4.9.4_p01.ebuild:
+ Version bump. Unm Unmasking.
+
+ 13 Feb 2011; Raúl Porcel <armin76@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild, geant-4.9.3_p02-r1.ebuild, geant-4.9.4.ebuild:
+ Drop sparc keywords
+
+ 07 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> geant-4.9.4.ebuild:
+ Fixed a forgotten flag, thanks Rafal Lalik bug #353740
+
+*geant-4.9.4 (22 Jan 2011)
+
+ 22 Jan 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.3_p02-r1.ebuild, files/geant-4.9.3-zlib.patch, +geant-4.9.4.ebuild,
+ +files/geant-4.9.4-datadir.patch, +files/geant-4.9.4-libdir.patch,
+ +files/geant-4.9.4-no-benchmarks.patch, +files/geant-4.9.4-no-examples.patch,
+ +files/geant-4.9.4-zlib.patch, metadata.xml:
+ Version bump, switched to cmake. Fixed Qt drivers bug #263450, bug #347279.
+ Removed G4WORKDIR bug #345855.
+
+*geant-4.9.3_p02-r1 (07 Nov 2010)
+
+ 07 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ -geant-4.9.3_p01.ebuild, -geant-4.9.3_p02.ebuild,
+ +geant-4.9.3_p02-r1.ebuild, +files/geant-4.9.3-respect_flags.patch:
+ Fix building with --as-needed wrt bug 344119, respect CXX. Drop old.
+
+ 10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild, geant-4.9.3_p01.ebuild, geant-4.9.3_p02.ebuild:
+ Fix openmotif dependency.
+
+*geant-4.9.3_p02 (29 Sep 2010)
+
+ 29 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-4.9.3_p02.ebuild:
+ Version bump
+
+ 12 Aug 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.2_p02.ebuild, -geant-4.9.3.ebuild, geant-4.9.3_p01.ebuild:
+ Change clhep dependency, clhep-2.1 api incompatible
+
+*geant-4.9.3_p01 (27 Apr 2010)
+
+ 27 Apr 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-4.9.3_p01.ebuild:
+ Version bump. Switched static flag to static-libs
+
+*geant-4.9.3 (08 Jan 2010)
+
+ 08 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -geant-4.9.2-r2.ebuild, +geant-4.9.3.ebuild,
+ +files/geant-4.9.3-zlib.patch:
+ Version bump, thanks Ben Bannier
+
+ 26 Dec 2009; Raúl Porcel <armin76@gentoo.org> geant-4.9.2_p02.ebuild:
+ sparc stable wrt #294442
+
+ 10 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.2_p02.ebuild:
+ Propagate compiler correctly, bug #296043
+
+ 07 Dec 2009; Jeroen Roovers <jer@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild:
+ Stable for HPPA (bug #294442).
+
+ 04 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-3.21.14-r2.ebuild:
+ Re-changing to old style patching at least until patch-2.6 is not buggy
+ and masked
+
+ 26 Nov 2009; Markus Meier <maekke@gentoo.org> geant-4.9.2_p02.ebuild:
+ amd64 stable, bug #294442
+
+ 26 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-3.21.14-r2.ebuild:
+ Fixing patch application with more recent versions
+
+ 26 Nov 2009; Christian Faulhammer <fauli@gentoo.org>
+ geant-4.9.2_p02.ebuild:
+ stable x86, bug 294442
+
+ 06 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> geant-4.9.2-r2.ebuild,
+ geant-4.9.2_p02.ebuild:
+ Removed alternative dependency on Qt metapackage
+
+*geant-4.9.2_p02 (23 Sep 2009)
+
+ 23 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -geant-4.9.1_p03.ebuild, -geant-4.9.2_p01.ebuild, +geant-4.9.2_p02.ebuild,
+ metadata.xml:
+ Version bump. Added aida USE flag, fixed Qt and GDML build options,
+ hopefully fixing examples compiling (bug #260102), thanks Matej and
+ Giovanni Fattori for their input
+
+ 05 May 2009; Christian Faulhammer <fauli@gentoo.org>
+ geant-3.21.14-r2.ebuild, geant-4.9.2-r2.ebuild:
+ stable x86, bug 245875
+
+ 17 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> geant-3.21.14-r2:
+ Fixed some latex font generation and made ebuild consistent with other
+ cernlib ebuilds
+
+ 23 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.2-r2.ebuild:
+ Added building of opengl qt4 driver, thanks merkel@kph.uni-mainz.de (bug
+ #263450) for noticing
+
+ 22 Mar 2009; Jeremy Olexa <darkside@gentoo.org> geant-4.9.2-r2.ebuild:
+ amd64 stable, bug 245875
+
+ 22 Mar 2009; Jeremy Olexa <darkside@gentoo.org> geant-3.21.14-r2.ebuild:
+ amd64 stable, bug 245875
+
+*geant-4.9.2_p01 (18 Mar 2009)
+
+ 18 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-3.21.14-r2.ebuild, +geant-4.9.2_p01.ebuild:
+ Version bump (bug fixes only)
+
+ 05 Mar 2009; Ferris McCormick <fmccor@gentoo.org> geant-4.9.2-r2.ebuild:
+ Sparc stable, although early. See Bug #245875 --- needed for gcc-4.3 (Bug
+ #245160).
+
+ 05 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.2-r2.ebuild:
+ Fixed linking qt4 libraries, added G4WORKDIR to make it work on paludis
+ and a bit of ebuild cleaning
+
+ 03 Mar 2009; Ferris McCormick <fmccor@gentoo.org> geant-3.21.14-r2.ebuild:
+ Sparc stable, part of Bug #245875.
+
+*geant-4.9.2-r2 (27 Feb 2009)
+
+ 27 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> -geant-4.9.2.ebuild,
+ -geant-4.9.2-r1.ebuild, +geant-4.9.2-r2.ebuild:
+ Adding fixes from Benjamin Bannier to include linking when building
+ examples, and a syntax error caught by Matej Batic, see bug #260102
+
+*geant-4.9.2-r1 (19 Jan 2009)
+
+ 19 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/geant-4.9.2-zlib.patch, +geant-4.9.2-r1.ebuild:
+ Added a patch to avoid linking to G4zlib, closing bug #255017, thanks to
+ Benjamin Bannier for the hint
+
+*geant-4.9.2 (10 Jan 2009)
+
+ 10 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org> +geant-4.9.2.ebuild:
+ Version bump. Switched to EAPI=2, added qt4 support, updated data files,
+ updated minimum dependencies, and now propagate LDFLAGS. Closing bug #253769.
+
+ 24 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -geant-4.9.1_p02.ebuild, geant-4.9.1_p03.ebuild:
+ Removed bundled zlib, closing bug #248423
+
+*geant-4.9.1_p03 (23 Sep 2008)
+
+ 23 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-4.9.1_p03.ebuild:
+ Version bump. Closing bug #238132.
+
+ 06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
+ Add USE flag description to metadata wrt GLEP 56.
+
+ 17 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.1_p02.ebuild:
+ Fixed the make global step to not remove previous built granula libaries,
+ see bug #231314, thanks Benjamin Bannier.
+
+ 15 Jul 2008; Ferris McCormick <fmccor@gentoo.org> geant-4.9.1_p02.ebuild:
+ Add ~sparc for testing and for sci-physics/root --- Bug #230716 which see
+ for comments.
+
+ 15 Jul 2008; Ferris McCormick <fmccor@gentoo.org> geant-3.21.14-r2.ebuild:
+ Add ~sparc for testing, dependency required for Bug #230716.
+
+ 15 Jul 2008; Jeroen Roovers <jer@gentoo.org> geant-4.9.1_p02.ebuild:
+ Marked ~hppa (bug #230716).
+
+ 14 Jul 2008; Jeroen Roovers <jer@gentoo.org> geant-3.21.14-r2.ebuild:
+ Marked ~hppa (bug #230716).
+
+ 10 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.1_p02.ebuild:
+ Fix some global libraries issues, see bug #231314, thanks Benjamin Bannier
+ for his patch.
+
+ 06 Jul 2008; Jeroen Roovers <jer@gentoo.org> geant-3.21.14-r1.ebuild:
+ Fix duplicate KEYWORDS definition.
+
+ 06 Jul 2008; Jeroen Roovers <jer@gentoo.org> geant-3.21.14-r2.ebuild:
+ Fix duplicate KEYWORDS definition.
+
+ 29 Jun 2008; Torsten Veller <tove@gentoo.org> geant-3.21.14-r1.ebuild,
+ geant-3.21.14-r2.ebuild:
+ Add missing die: || "..." -> || die "..."
+
+ 27 Jun 2008; Ulrich Mueller <ulm@gentoo.org> geant-3.21.14-r1.ebuild,
+ geant-3.21.14-r2.ebuild, geant-4.9.1_p02.ebuild:
+ Change dependency from virtual/motif to x11-libs/openmotif, bug 224749.
+
+*geant-4.9.1_p02 (06 Jun 2008)
+*geant-3.21.14-r2 (06 Jun 2008)
+
+ 06 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ -geant-3.21.14.ebuild, +geant-3.21.14-r2.ebuild, +geant-4.9.1_p02.ebuild:
+ Added major version bump for geant-4, slotted. Thanks much to Benjamin
+ Bennier for his work (bug #212221). Now geant-3 is also slotted, and got a
+ revision bump
+
+*geant-4.9.1_p02 (06 Jun 2008)
+*geant-3.21.14-r2 (06 Jun 2008)
+
+ 06 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ -geant-3.21.14.ebuild, +geant-3.21.14-r2.ebuild, +geant-4.9.1_p02.ebuild:
+ Added major version bump for geant-4, slotted. Thanks much to Benjamin
+ Bennier for his work (bug #212221). Now geant-3 is also slotted, and got a
+ revision bump
+
+*geant-3.21.14-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-3.21.14-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
+
+*geant-3.21.14 (24 Aug 2007)
+
+ 24 Aug 2007; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +geant-3.21.14.ebuild:
+ Initial import.
+
diff --git a/sci-physics/geant/Manifest b/sci-physics/geant/Manifest
new file mode 100644
index 0000000..a608ce2
--- /dev/null
+++ b/sci-physics/geant/Manifest
@@ -0,0 +1,6 @@
+AUX geant-4.9.4-zlib.patch 963 RMD160 3e4edc4c3eacb88c31d94f3b0cabccb7a0b8cbb4 SHA1 1dcef047511da7aca2e04e116b36cccb18e3ef49 SHA256 6fc50ad04fcd6b646635ca42ed2b42d26b9f46ec8bcfc5bedabb89134bb0cdfe
+AUX geant-4.9.5-scripts-only-dataenv.patch 1958 RMD160 7123f6a671f51563516a4f2922e03a2fb311bc27 SHA1 93c020e7ee67a5846441526fe6a5b237ce9d01ab SHA256 c8e4e4f524d3f4961245f95ecaee36e78de00f9bf2beee0b19e78ee341b0d7bb
+DIST geant4.9.5.tar.gz 28458437 RMD160 24e78b5243aa9ec47a48bbcb6d2afb4d9fe22dbf SHA1 846b48e82c1709d77a8f490fd12b039acc1d0cf9 SHA256 b6b31752319805052fb765f89ca38a23fb299a0a5bf900daeacd1950d6c9a597
+EBUILD geant-4.9.5-r1.ebuild 2912 RMD160 ca16b816afc3e08a0912028b5a2328ff25cff310 SHA1 2adfe168097e6409673294d0b0e668a29e414c21 SHA256 3da4b77ce0a599f8a8edb8d9808879178788e2aabdc5201189898f40966f2151
+MISC ChangeLog 11007 RMD160 37a7d59bf4e97e45fa355ea60e316943639f7c35 SHA1 854df3a4442d95bd3147d1707f4d80e9f08508da SHA256 915c51e36a9de4147c35a3242a963194b91fb38d6273594fb196ca272580b3eb
+MISC metadata.xml 1569 RMD160 b4e64715d0d29b17b7fc46da45f4ebbff41fc380 SHA1 b30f9de8adea84a688b1343115afa304d5b0de4f SHA256 532c396760c97bbf207439e4f189679bbe02fda61d33446beeebc5f855b36f63
diff --git a/sci-physics/geant/files/geant-4.9.4-zlib.patch b/sci-physics/geant/files/geant-4.9.4-zlib.patch
new file mode 100644
index 0000000..1aaa3e5
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-zlib.patch
@@ -0,0 +1,34 @@
+--- source/visualization/HepRep/sources.cmake.orig 2011-12-02 15:07:49.000000000 +0000
++++ source/visualization/HepRep/sources.cmake 2011-12-18 06:21:22.000000000 +0000
+@@ -91,7 +91,7 @@
+ G4specsolids
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+ G4digits_hits
+ G4geometry
+@@ -102,7 +102,7 @@
+ G4modeling
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ )
+
+--- source/visualization/externals/gl2ps/sources.cmake.orig 2011-12-02 16:07:56.000000000 +0100
++++ source/visualization/externals/gl2ps/sources.cmake 2012-03-09 14:09:26.965148002 +0100
+@@ -49,9 +49,9 @@
+ G4OpenGL2PSAction.cc
+ gl2ps.cc
+ GRANULAR_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ ${OPENGL_LIBRARIES}
+ )
diff --git a/sci-physics/geant/files/geant-4.9.5-scripts-only-dataenv.patch b/sci-physics/geant/files/geant-4.9.5-scripts-only-dataenv.patch
new file mode 100644
index 0000000..15ee1c0
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.5-scripts-only-dataenv.patch
@@ -0,0 +1,55 @@
+diff --git a/cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake b/cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake
+index 41a88c4..e93b923 100644
+--- a/cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake
++++ b/cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake
+@@ -678,15 +678,4 @@ foreach(_shell bourne;cshell)
+ @ONLY
+ )
+
+- # Install it to the required location
+- install(FILES
+- ${PROJECT_BINARY_DIR}/InstallTreeFiles/${_scriptfullname}
+- DESTINATION ${CMAKE_INSTALL_BINDIR}
+- PERMISSIONS
+- OWNER_READ OWNER_WRITE OWNER_EXECUTE
+- GROUP_READ GROUP_EXECUTE
+- WORLD_READ WORLD_EXECUTE
+- COMPONENT Runtime
+- )
+ endforeach()
+-
+diff --git a/cmake/Templates/geant4-env-skeleton.in b/cmake/Templates/geant4-env-skeleton.in
+index ea8f104..db68b9c 100644
+--- a/cmake/Templates/geant4-env-skeleton.in
++++ b/cmake/Templates/geant4-env-skeleton.in
+@@ -1,30 +1,3 @@
+-#!@GEANT4_TC_SHELL_PROGRAM
+-
+-#----------------------------------------------------------------------------
+-# @GEANT4_TC_SHELL_FAMILY@ environment setup script for Geant4 @Geant4_VERSION@
+-#
+-# This script will configure your environment so that any Geant4 supplied
+-# tools, libraries and data are available in your PATH, library paths etc.
+-# Data libraries will only be setup if they were installed as part of the
+-# Geant4 installation.
+-#
+-# Source this script to perform the setup.
+-#
+-# This script is autogenerated by CMake DO NOT EDIT
+-#
+-
+-#----------------------------------------------------------------------------
+-# Locate directory of self
+-#
+-@GEANT4_ENV_SELFLOCATE_COMMAND@
+-
+-
+-#----------------------------------------------------------------------------
+-# Setup binary and library paths...
+-#
+-@GEANT4_ENV_BINPATH_SETUP@
+-@GEANT4_ENV_LIBPATH_SETUP@
+-
+ #----------------------------------------------------------------------------
+ # Resource file paths
+ # Data Library Paths are only set if they were installed by CMake
diff --git a/sci-physics/geant/geant-4.9.5-r1.ebuild b/sci-physics/geant/geant-4.9.5-r1.ebuild
new file mode 100644
index 0000000..17e713f
--- /dev/null
+++ b/sci-physics/geant/geant-4.9.5-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.5-r1.ebuild,v 1.1 2012/03/13 21:52:56 bicatali Exp $
+
+EAPI=4
+
+inherit cmake-utils eutils fortran-2 versionator
+
+PV1=$(get_version_component_range 1 ${PV})
+PV2=$(get_version_component_range 2 ${PV})
+PV3=$(get_version_component_range 3 ${PV})
+MYP=${PN}$(replace_version_separator 3 .)
+
+DESCRIPTION="Toolkit for simulation of passage of particles through matter"
+HOMEPAGE="http://geant4.cern.ch/"
+SRC_URI="http://geant4.cern.ch/support/source/${MYP}.tar.gz"
+
+LICENSE="geant4"
+SLOT="4"
+KEYWORDS="~amd64-linux ~x86-linux"
+IUSE="+data dawn examples gdml geant3 granular motif opengl openinventor
+ raytracerx qt4 static-libs test vrml zlib"
+
+RDEPEND="virtual/fortran
+ >=sci-physics/clhep-2.1.1
+ dawn? ( media-gfx/dawn )
+ gdml? ( dev-libs/xerces-c )
+ motif? ( x11-libs/openmotif:0 )
+ opengl? ( virtual/opengl )
+ openinventor? ( media-libs/openinventor )
+ raytracerx? ( x11-libs/libX11 x11-libs/libXmu )
+ qt4? ( x11-libs/qt-gui:4 opengl? ( x11-libs/qt-opengl:4 ) )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.9.4-zlib.patch \
+ "${FILESDIR}"/${PN}-4.9.5-scripts-only-dataenv.patch )
+
+src_prepare() {
+ sed "s,-lG4clhep,$(clhep-config --libs)," config/binmake.gmk || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DGEANT4_USE_SYSTEM_CLHEP=ON
+ $(use openinventor && echo "-DINVENTOR_SOXT_LIBRARY=${EROOT}usr/$(get_libdir)/libInventorXt.so")
+ $(cmake-utils_use data GEANT4_INSTALL_DATA)
+ $(cmake-utils_use dawn GEANT4_USE_NETWORKDAWN)
+ $(cmake-utils_use gdml GEANT4_USE_GDML)
+ $(cmake-utils_use geant3 GEANT4_USE_G3TOG4)
+ $(cmake-utils_use granular GEANT4_BUILD_GRANULAR_BUILD)
+ $(cmake-utils_use motif GEANT4_USE_XM)
+ $(cmake-utils_use opengl GEANT4_USE_OPENGL_X11)
+ $(cmake-utils_use openinventor GEANT4_USE_INVENTOR)
+ $(cmake-utils_use qt4 GEANT4_USE_QT)
+ $(cmake-utils_use raytracerx GEANT4_USE_RAYTRACER_X11)
+ $(cmake-utils_use test GEANT4_ENABLE_TESTING)
+ $(cmake-utils_use vrml GEANT4_USE_NETWORKVRML)
+ $(cmake-utils_use zlib GEANT4_USE_SYSTEM_ZLIB)
+ $(cmake-utils_use_build static-libs STATIC_LIBS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/share/doc/${PF}
+ local mypv="${PV1}.${PV2}.${PV3}"
+ doins ReleaseNotes/ReleaseNotes${mypv}.html
+ [[ -e ReleaseNotes/Patch${mypv}-1.txt ]] && \
+ dodoc ReleaseNotes/Patch${mypv}-*.txt
+ use examples && doins -r examples
+ if use data ; then
+ sed "s,export \(G4.\+DATA=\"\).*\(/share/Geant.\+/data/.\+\); pwd\`,\1${EPREFIX}/usr\2," \
+ "${CMAKE_BUILD_DIR}/InstallTreeFiles/geant4.sh" > 99geant
+ doenvd 99geant
+ fi
+}
+
+pkg_postinst() {
+ elog "The following scripts are provided for backward compatibility:"
+ elog "$(ls -1 ${EROOT}usr/share/Geant4-${PV2}.${PV3}.*/geant4make/*sh)"
+}
diff --git a/sci-physics/geant/metadata.xml b/sci-physics/geant/metadata.xml
new file mode 100644
index 0000000..7d3677c
--- /dev/null
+++ b/sci-physics/geant/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
+ Geant simulates the passage of subatomic particles through matter, for
+ instance, particle detectors. Geant 3 simulations are performed by
+ linking Fortran code supplied by the user with the Geant libraries,
+ then running the resulting executable. This package includes gxint,
+ the script used to perform this linking step.
+ Geant 4 is a complete rewrite in C++ with addition of other modern
+ features and detectors.
+</longdescription>
+ <use>
+ <flag name="athena">Enable the MIT Athena (<pkg>x11-libs/libXaw</pkg>)
+ widget set (default is Motif)</flag>
+ <flag name="data">Add a lot of standard physics data files for geant4</flag>
+ <flag name="dawn">Add support for <pkg>media-gfx/dawn</pkg> (3D postscript
+ rendering)</flag>
+ <flag name="gdml">Enable geometry markup language for xml</flag>
+ <flag name="geant3">Add compatibility for geant321 to geant4</flag>
+ <flag name="global">Produce a huge global library instead of small
+ ones</flag>
+ <flag name="granular">Produce many small libraries instead of global ones</flag>
+ <flag name="aida">Add support for Abstract Interfaces for Data Analysis </flag>
+ <flag name="openinventor">Add support for <pkg>media-libs/openinventor</pkg>
+ SGI toolkit</flag>
+ <flag name="raytracerx">Enable raytracing for physics events</flag>
+ <flag name="vrml">Enable output of geant4 in vrml formats</flag>
+ </use>
+</pkgmetadata>