summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2015-08-12 12:15:44 +0900
committerBenda Xu <heroxbd@gentoo.org>2015-08-12 12:15:44 +0900
commitef1a9de5bf0afa3e9829dad99ba521daf27881bc (patch)
tree410140988f0e3f7ff6c8222e0b3396dfa27dd479 /dev-lang
parentdev-lang/ocaml: carbon copy from gentoo-x86. (diff)
downloadheroxbd-ef1a9de5bf0afa3e9829dad99ba521daf27881bc.tar.gz
heroxbd-ef1a9de5bf0afa3e9829dad99ba521daf27881bc.tar.bz2
heroxbd-ef1a9de5bf0afa3e9829dad99ba521daf27881bc.zip
perl: track perl-5.22 raw files.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/files/eblits/pkg_postinst-v50220001.eblit67
-rw-r--r--dev-lang/perl/files/eblits/pkg_postrm-v50220001.eblit12
-rw-r--r--dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit72
-rw-r--r--dev-lang/perl/perl-5.22.0.ebuild120
4 files changed, 271 insertions, 0 deletions
diff --git a/dev-lang/perl/files/eblits/pkg_postinst-v50220001.eblit b/dev-lang/perl/files/eblits/pkg_postinst-v50220001.eblit
new file mode 100644
index 0000000..a268f78
--- /dev/null
+++ b/dev-lang/perl/files/eblits/pkg_postinst-v50220001.eblit
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+eblit-perl-pkg_postinst() {
+ dual_scripts
+
+ if [[ "${ROOT}" = "/" ]] ; then
+ local INC DIR file
+ INC=$(perl -e 'for $line (@INC) { next if $line eq "."; next if $line =~ m/'${SHORT_PV}'|etc|local|perl$/; print "$line\n" }')
+ einfo "Removing old .ph files"
+ for DIR in ${INC} ; do
+ if [[ -d "${DIR}" ]] ; then
+ for file in $(find "${DIR}" -name "*.ph" -type f ) ; do
+ rm -f "${file}"
+ einfo "<< ${file}"
+ done
+ fi
+ done
+ # Silently remove the now empty dirs
+ for DIR in ${INC} ; do
+ if [[ -d "${DIR}" ]] ; then
+ find "${DIR}" -depth -type d -print0 | xargs -0 -r rmdir &> /dev/null
+ fi
+ done
+
+# ebegin "Generating ConfigLocal.pm (ignore any error)"
+# enc2xs -C
+
+ einfo "Converting C header files to the corresponding Perl format (ignore any error)"
+ # Prefix note: unprefixed as this is all kernel/libc stuff that we never provide
+ pushd /usr/include >/dev/null
+ h2ph -Q -a -d "${EPREFIX}"${ARCH_LIB} \
+ asm/termios.h syscall.h syslimits.h syslog.h sys/ioctl.h \
+ sys/socket.h sys/time.h wait.h sysexits.h
+ popd >/dev/null
+
+# This has been moved into a function because rumor has it that a future release
+# of portage will allow us to check what version was just removed - which means
+# we will be able to invoke this only as needed :)
+ # Tried doing this via -z, but $INC is too big...
+ #if [[ "${INC}x" != "x" ]]; then
+ # cleaner_msg
+ #fi
+ fi
+}
+
+cleaner_msg() {
+ eerror "You have had multiple versions of perl. It is recommended"
+ eerror "that you run perl-cleaner now. perl-cleaner will"
+ eerror "assist with this transition. This script is capable"
+ eerror "of cleaning out old .ph files, rebuilding modules for "
+ eerror "your new version of perl, as well as re-emerging"
+ eerror "applications that compiled against your old libperl$(get_libname)"
+ eerror
+ eerror "PLEASE DO NOT INTERRUPT THE RUNNING OF THIS SCRIPT."
+ eerror "Part of the rebuilding of applications compiled against "
+ eerror "your old libperl involves temporarily unmerging"
+ eerror "them - interruptions could leave you with unmerged"
+ eerror "packages before they can be remerged."
+ eerror ""
+ eerror "If you have run perl-cleaner and a package still gives"
+ eerror "you trouble, and re-emerging it fails to correct"
+ eerror "the problem, please check http://bugs.gentoo.org/"
+ eerror "for more information or to report a bug."
+ eerror ""
+}
diff --git a/dev-lang/perl/files/eblits/pkg_postrm-v50220001.eblit b/dev-lang/perl/files/eblits/pkg_postrm-v50220001.eblit
new file mode 100644
index 0000000..5bead2a
--- /dev/null
+++ b/dev-lang/perl/files/eblits/pkg_postrm-v50220001.eblit
@@ -0,0 +1,12 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+eblit-perl-pkg_postrm(){
+ dual_scripts
+
+# if [[ -e ${ARCH_LIB}/Encode/ConfigLocal.pm ]] ; then
+# ebegin "Removing ConfigLocal.pm"
+# rm "${ARCH_LIB}/Encode/ConfigLocal.pm"
+# fi
+}
diff --git a/dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit b/dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit
new file mode 100644
index 0000000..a2b0957
--- /dev/null
+++ b/dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+eblit-perl-pkg_setup() {
+ case ${CHOST} in
+ *-freebsd*) osname="freebsd" ;;
+ *-dragonfly*) osname="dragonfly" ;;
+ *-netbsd*) osname="netbsd" ;;
+ *-openbsd*) osname="openbsd" ;;
+ *-darwin*) osname="darwin" ;;
+ *-interix*) osname="interix" ;;
+ *-aix*) osname="aix" ;;
+ *) osname="linux" ;;
+ esac
+
+ myarch="${CHOST%%-*}-${osname}"
+ if use debug ; then
+ myarch+="-debug"
+ fi
+ if use ithreads ; then
+ mythreading="-multi"
+ myarch+="-thread"
+ fi
+
+ LIBPERL="libperl$(get_libname ${MY_PV} )"
+ PRIV_LIB="/usr/$(get_libdir)/perl5/${MY_PV}"
+ ARCH_LIB="/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading}"
+ SITE_LIB="/usr/local/$(get_libdir)/perl5/${MY_PV}"
+ SITE_ARCH="/usr/local/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading}"
+ VENDOR_LIB="/usr/$(get_libdir)/perl5/vendor_perl/${MY_PV}"
+ VENDOR_ARCH="/usr/$(get_libdir)/perl5/vendor_perl/${MY_PV}/${myarch}${mythreading}"
+
+ if use ithreads ; then
+ echo ""
+ ewarn "THREADS WARNING:"
+ ewarn "PLEASE NOTE: You are compiling ${MY_P} with"
+ ewarn "interpreter-level threading enabled."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ fi
+ check_rebuild
+ dual_scripts
+}
+
+check_rebuild() {
+ if has_version "<dev-lang/perl-${SHORT_PV}" ; then
+ echo ""
+ ewarn "UPDATE THE PERL MODULES:"
+ ewarn "After updating dev-lang/perl the installed Perl modules will"
+ ewarn "have to be re-installed. In most cases, this is done automatically"
+ ewarn "by the package manager, but you should still call perl-cleaner to"
+ ewarn "make sure your system is consistent."
+ ewarn "Use: perl-cleaner --all"
+ elif has_version dev-lang/perl ; then
+ # doesnot work
+ #if ! has_version dev-lang/perl[ithreads=,debug=] ; then
+ #if ! has_version dev-lang/perl[ithreads=] || ! has_version dev-lang/perl[debug=] ; then
+ if ( use ithreads && ! has_version dev-lang/perl[ithreads] ) || \
+ ( ! use ithreads && has_version dev-lang/perl[ithreads] ) || \
+ ( use debug && ! has_version dev-lang/perl[debug] ) || \
+ ( ! use debug && has_version dev-lang/perl[debug] ) ; then
+ echo ""
+ ewarn "TOGGLED USE-FLAGS WARNING:"
+ ewarn "You changed one of the use-flags ithreads or debug."
+ ewarn "You must rebuild all perl-modules installed."
+ ewarn "Use: perl-cleaner --modules ; perl-cleaner --force --libperl"
+ fi
+ fi
+}
+
diff --git a/dev-lang/perl/perl-5.22.0.ebuild b/dev-lang/perl/perl-5.22.0.ebuild
new file mode 100644
index 0000000..f1f5b24
--- /dev/null
+++ b/dev-lang/perl/perl-5.22.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessing
+
+PATCH_VER=1
+
+PERL_OLDVERSEN=""
+MODULE_AUTHOR=SHAY
+
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
+MY_PV="${PV%_rc*}"
+
+DESCRIPTION="Larry Wall's Practical Extraction and Report Language"
+
+SRC_URI="
+ mirror://cpan/src/5.0/${MY_P}.tar.bz2
+ mirror://cpan/authors/id/${MODULE_AUTHOR:0:1}/${MODULE_AUTHOR:0:2}/${MODULE_AUTHOR}/${MY_P}.tar.bz2
+ mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.xz
+ http://dev.gentoo.org/~civil/distfiles/${MY_P}-patches-${PATCH_VER}.tar.xz
+"
+HOMEPAGE="http://www.perl.org/"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0/${SHORT_PV}"
+KEYWORDS="~alpha ~amd64 ~amd64-fbsd ~amd64-linux ~arm ~arm64 ~hppa ~hppa-hpux ~ia64 ~ia64-hpux ~ia64-linux ~m68k ~m68k-mint ~mips ~ppc ~ppc64 ~ppc-aix ~ppc-macos ~s390 ~sh ~sparc ~sparc64-solaris ~sparc-solaris ~x64-freebsd ~x64-macos ~x64-solaris ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="berkdb debug doc gdbm ithreads"
+
+RDEPEND="
+ berkdb? ( sys-libs/db:* )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
+ app-arch/bzip2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ !prefix? ( elibc_FreeBSD? ( sys-freebsd/freebsd-mk-defs ) )
+"
+PDEPEND="
+ >=app-admin/perl-cleaner-2.5
+ >=virtual/perl-File-Temp-0.230.400-r2
+ >=virtual/perl-Data-Dumper-2.154.0
+"
+# bug 390719, bug 523624
+
+S="${WORKDIR}/${MY_P}"
+
+dual_scripts() {
+ src_remove_dual perl-core/Archive-Tar 2.40.0 ptar ptardiff ptargrep
+ src_remove_dual perl-core/Digest-SHA 5.950.0 shasum
+ src_remove_dual perl-core/CPAN 2.110.0 cpan
+ src_remove_dual perl-core/Encode 2.720.0 enc2xs piconv
+ src_remove_dual perl-core/ExtUtils-MakeMaker 7.40.100 instmodsh
+ src_remove_dual perl-core/ExtUtils-ParseXS 3.280.0 xsubpp
+ src_remove_dual perl-core/IO-Compress 2.68.0 zipdetails
+ src_remove_dual perl-core/JSON-PP 2.273.0 json_pp
+ src_remove_dual perl-core/Module-CoreList 5.201.505.200 corelist
+ src_remove_dual perl-core/Pod-Parser 1.630.0 pod2usage podchecker podselect
+ src_remove_dual perl-core/Pod-Perldoc 3.250.0 perldoc
+ src_remove_dual perl-core/Test-Harness 3.350.0 prove
+ src_remove_dual perl-core/podlators 2.5.3 pod2man pod2text
+ src_remove_dual_man perl-core/podlators 2.5.3 /usr/share/man/man1/perlpodstyle.1
+}
+
+# eblit-include [--skip] <function> [version]
+eblit-include() {
+ local skipable=false
+ [[ $1 == "--skip" ]] && skipable=true && shift
+ [[ $1 == pkg_* ]] && skipable=true
+
+ local e v func=$1 ver=$2
+ [[ -z ${func} ]] && die "Usage: eblit-include <function> [version]"
+ for v in ${ver:+-}${ver} -${PVR} -${PV} "" ; do
+ e="${FILESDIR}/eblits/${func}${v}.eblit"
+ if [[ -e ${e} ]] ; then
+ . "${e}"
+ return 0
+ fi
+ done
+ ${skipable} && return 0
+ die "Could not locate requested eblit '${func}' in ${FILESDIR}/eblits/"
+}
+
+# eblit-run-maybe <function>
+# run the specified function if it is defined
+eblit-run-maybe() {
+ [[ $(type -t "$@") == "function" ]] && "$@"
+}
+
+# eblit-run <function> [version]
+# aka: src_unpack() { eblit-run src_unpack ; }
+eblit-run() {
+ eblit-include --skip common "${*:2}"
+ eblit-include "$@"
+ eblit-run-maybe eblit-$1-pre
+ eblit-${PN}-$1
+ eblit-run-maybe eblit-$1-post
+}
+
+src_prepare() { eblit-run src_prepare v50160001 ; }
+src_configure() { eblit-run src_configure v50180002 ; }
+#src_compile() { eblit-run src_compile v50160001 ; }
+src_test() {
+ export NO_GENTOO_NETWORK_TESTS=1;
+ eblit-run src_test v50160001 ;
+}
+src_install() { eblit-run src_install v50200001 ; }
+
+# FILESDIR might not be available during binpkg install
+# FIXME: version passing
+for x in setup {pre,post}{inst,rm} ; do
+ e="${FILESDIR}/eblits/pkg_${x}-v50220001.eblit"
+ if [[ -e ${e} ]] ; then
+ . "${e}"
+ eval "pkg_${x}() { eblit-run pkg_${x} v50160001 ; }"
+ fi
+done