summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-globalmenu/gnome-globalmenu-9999.ebuild')
-rw-r--r--gnome-extra/gnome-globalmenu/gnome-globalmenu-9999.ebuild51
1 files changed, 26 insertions, 25 deletions
diff --git a/gnome-extra/gnome-globalmenu/gnome-globalmenu-9999.ebuild b/gnome-extra/gnome-globalmenu/gnome-globalmenu-9999.ebuild
index 7ebcfe1..5126942 100644
--- a/gnome-extra/gnome-globalmenu/gnome-globalmenu-9999.ebuild
+++ b/gnome-extra/gnome-globalmenu/gnome-globalmenu-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
inherit autotools eutils gnome2
@@ -22,33 +24,24 @@ HOMEPAGE="http://code.google.com/p/gnome2-globalmenu/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="gnome test xfce"
+IUSE="gnome +introspection xfce"
-# XXX: vala dependency raised for build issues
-RDEPEND=">=x11-libs/gtk+-2.10.0
- >=dev-libs/glib-2.10.0
- >=gnome-base/gconf-2
- >=x11-libs/libwnck-2.16.0
- >=gnome-base/gnome-menus-2.16.0
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=dev-libs/glib-2.10:2
+ gnome-base/gconf:2
+ >=x11-libs/libwnck-2.16:1
+ >=gnome-base/gnome-menus-2.16:0
+ >=x11-libs/libX11-1.1.0
gnome? (
- >=gnome-base/gnome-panel-2.16.0
+ >=gnome-base/gnome-panel-2.16
>=x11-libs/libnotify-0.4.4 )
xfce? (
>=xfce-base/xfce4-panel-4.4.3 )
- >=x11-libs/libX11-1.1.0"
+"
DEPEND="${RDEPEND}
dev-util/intltool
- dev-util/pkgconfig
- >=dev-lang/vala-0.7.7"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --without-gir
- --docdir=/usr/share/doc/${PF}
- $(use_enable test tests)
- $(use_with gnome gnome-panel)
- $(use_with xfce xfce4-panel)"
-}
+ virtual/pkgconfig
+ >=dev-lang/vala-0.7.7:0.10"
src_unpack() {
if [[ ${PV} == "9999" ]]; then
@@ -60,7 +53,14 @@ src_unpack() {
}
src_prepare() {
- gnome2_src_prepare
+ G2CONF="${G2CONF}
+ --docdir=/usr/share/doc/${PF}
+ --without-gir
+ $(use_with gnome gnome-panel)
+ $(use_with xfce xfce4-panel)
+ VALAC_BIN=$(type -P valac-0.10)"
+ # Does not enable anything
+ #$(use_with introspection gir)
# INSTALL is not useful or existing depending on version
sed 's/\(doc_DATA.*\)INSTALL/\1/' \
@@ -69,6 +69,7 @@ src_prepare() {
# Fix compilation problem with --as-needed
epatch "${FILESDIR}/${PN}-0.7.7-as-needed.patch"
- intltoolize --force --copy --automake || die "intltoolize failed"
AT_M4DIR="autotools" eautoreconf
-}
+
+ gnome2_src_prepare
+} \ No newline at end of file