summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-12-07 18:28:24 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2014-12-07 19:00:04 +0100
commit247dd2be66fba6c6ed81b749295e5211bd8708c3 (patch)
treeb2a9d1c6980cbc51c110081dba5753638b984515 /gnome-extra
parentapp-editors/gedit-code-assistance: 0.2.0 → 0.3.1 (diff)
downloadeva-247dd2be66fba6c6ed81b749295e5211bd8708c3.tar.gz
eva-247dd2be66fba6c6ed81b749295e5211bd8708c3.tar.bz2
eva-247dd2be66fba6c6ed81b749295e5211bd8708c3.zip
gnome-extra/gtkhtml: restore gtkhtml:3.14 from gentoo-x86, needed for gnotime
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gtkhtml/Manifest11
-rw-r--r--gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch25
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild61
-rw-r--r--gnome-extra/gtkhtml/metadata.xml8
4 files changed, 105 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/Manifest b/gnome-extra/gtkhtml/Manifest
new file mode 100644
index 0000000..f224808
--- /dev/null
+++ b/gnome-extra/gtkhtml/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gtkhtml-3.32.2.tar.bz2 1217025 SHA256 8746053cf709e1de37c7ac775ab1364ddda4b75167660ed7f98a237b3797e39f SHA512 a641a6e2208ad9db9ab3c3dc4696cf010b70f64d302b6f889a275db396544570ee5c894835a18ea94699375d0e2fd91fd7414a0546ce5f62bcb6d603d331b1d5 WHIRLPOOL e6563edfd31a430853533dbdc3a07101e919c672b3ce79f6cf94167067c615e60b5677712cfa5672767895f099cc548efe821d1b1515e1f84c5ddd19a5f9a73f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlSEjjgACgkQ1fmVwcYIWAZTSACfYbSo6t1qL0DU1J5U8HmIkPFo
+FJsAoL0UepKw4iCW9gKKZVq9s279tZqd
+=W732
+-----END PGP SIGNATURE-----
diff --git a/gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch b/gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch
new file mode 100644
index 0000000..5109cbc
--- /dev/null
+++ b/gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch
@@ -0,0 +1,25 @@
+From b9882960dab978b85cbd32fc9b31e588c8c817ff Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 10 Oct 2012 23:37:48 +0200
+Subject: [PATCH] Drop deprecated g_thread_init
+
+---
+ components/editor/main.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/components/editor/main.c b/components/editor/main.c
+index 0a0a37f..3c729a2 100644
+--- a/components/editor/main.c
++++ b/components/editor/main.c
+@@ -373,8 +373,6 @@ main (gint argc, gchar **argv)
+ bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
+ textdomain (GETTEXT_PACKAGE);
+
+- g_thread_init (NULL);
+-
+ gtk_init (&argc, &argv);
+
+ editor = gtkhtml_editor_new ();
+--
+1.7.12
+
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild
new file mode 100644
index 0000000..f65a362
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/Attic/gtkhtml-3.32.2.ebuild,v 1.10 2014/11/13 11:59:18 pacho dead $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Lightweight HTML rendering/printing/editing engine"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="3.14"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.24:2
+ >=x11-libs/gtk+-2.20:2
+ >=x11-themes/gnome-icon-theme-2.22.0
+ >=gnome-base/orbit-2
+ >=app-text/enchant-1.1.7
+ gnome-base/gconf:2
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-deprecated-warning-flags"
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ # Fix build with recent glib, bug #436462
+ epatch "${FILESDIR}/${P}-g_thread_init.patch"
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ # Remove .la files since old will be removed anyway while updating
+ find "${ED}" -name "*.la" -delete || die "remove of la files failed"
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libgtkhtml-editor.so.0
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ preserve_old_lib_notify /usr/$(get_libdir)/libgtkhtml-editor.so.0
+}
diff --git a/gnome-extra/gtkhtml/metadata.xml b/gnome-extra/gtkhtml/metadata.xml
new file mode 100644
index 0000000..23310c6
--- /dev/null
+++ b/gnome-extra/gtkhtml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+</pkgmetadata>