summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch')
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch b/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
index 8376ab8..156b1f9 100644
--- a/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
+++ b/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
@@ -1,6 +1,6 @@
diff -u -r -N clapack-3.2.1-CMAKE-orig/CMakeLists.txt clapack-3.2.1-CMAKE/CMakeLists.txt
--- clapack-3.2.1-CMAKE-orig/CMakeLists.txt 2009-08-10 20:46:33.000000000 +0200
-+++ clapack-3.2.1-CMAKE/CMakeLists.txt 2010-08-27 01:42:37.000000000 +0200
++++ clapack-3.2.1-CMAKE/CMakeLists.txt 2010-08-27 01:56:16.000000000 +0200
@@ -18,8 +18,6 @@
add_definitions(-DNO_BLAS_WRAP)
endif()
@@ -23,16 +23,19 @@ diff -u -r -N clapack-3.2.1-CMAKE-orig/CMakeLists.txt clapack-3.2.1-CMAKE/CMakeL
+
diff -u -r -N clapack-3.2.1-CMAKE-orig/SRC/CMakeLists.txt clapack-3.2.1-CMAKE/SRC/CMakeLists.txt
--- clapack-3.2.1-CMAKE-orig/SRC/CMakeLists.txt 2009-08-10 19:47:54.000000000 +0200
-+++ clapack-3.2.1-CMAKE/SRC/CMakeLists.txt 2010-08-27 00:54:03.000000000 +0200
-@@ -375,6 +375,6 @@
++++ clapack-3.2.1-CMAKE/SRC/CMakeLists.txt 2010-08-27 08:51:54.000000000 +0200
+@@ -375,6 +375,9 @@
if(BUILD_COMPLEX16)
set(ALLOBJ ${ZLASRC} ${ALLAUX} ${DZLAUX})
endif()
-add_library(lapack ${ALLOBJ} ${ALLXOBJ})
-target_link_libraries(lapack blas)
-+add_library(clapack ${ALLOBJ} ${ALLXOBJ})
++add_library(clapack SHARED ${ALLOBJ} ${ALLXOBJ})
+target_link_libraries(clapack blas f2c)
++install(TARGETS clapack LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++
++install(FILES ../INCLUDE/clapack.h DESTINATION include)
diff -u -r -N clapack-3.2.1-CMAKE-orig/TESTING/EIG/CMakeLists.txt clapack-3.2.1-CMAKE/TESTING/EIG/CMakeLists.txt
--- clapack-3.2.1-CMAKE-orig/TESTING/EIG/CMakeLists.txt 2009-08-10 19:47:54.000000000 +0200
+++ clapack-3.2.1-CMAKE/TESTING/EIG/CMakeLists.txt 2010-08-27 00:26:48.000000000 +0200