aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/schakal')
-rw-r--r--sci-chemistry/schakal/Manifest6
-rw-r--r--sci-chemistry/schakal/schakal-99.ebuild72
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-chemistry/schakal/Manifest b/sci-chemistry/schakal/Manifest
new file mode 100644
index 0000000..7ebd355
--- /dev/null
+++ b/sci-chemistry/schakal/Manifest
@@ -0,0 +1,6 @@
+MD5 e9eff222fc8bc0a9417e209b974cea89 files/digest-gtk-gamess-1.04.1 253
+RMD160 26dac9544c8b0a3e9c5e4ce7136d7ad70c81fe1e files/digest-gtk-gamess-1.04.1 253
+SHA256 f4be243d027c7527ed0fdca0af8f8b3b188bb96ef32fda23aaad0d8d6f2c9ef8 files/digest-gtk-gamess-1.04.1 253
+MD5 a1daae598930e217f99793d7ddeda5af gtk-gamess-1.04.1.ebuild 672
+RMD160 ce67c36f994fa85f64f3cae5b651c1daf8fd8929 gtk-gamess-1.04.1.ebuild 672
+SHA256 8aa9a3a50ddc725acd162bab6192fbb5788d645f2dd14b72f2bb1fac309f618d gtk-gamess-1.04.1.ebuild 672
diff --git a/sci-chemistry/schakal/schakal-99.ebuild b/sci-chemistry/schakal/schakal-99.ebuild
new file mode 100644
index 0000000..ac9dada
--- /dev/null
+++ b/sci-chemistry/schakal/schakal-99.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/colordiff/colordiff-1.0.5-r2.ebuild,v 1.7 2005/08/17 18:08:02 grobian Exp $
+
+# This is an incredibly ugly UI, but it can create beautiful graphics.
+# Ebuild not yet in a working state, but very close. src_install() just needs
+# finishing.
+
+inherit fortran toolchain-funcs
+
+DESCRIPTION="Program for the graphical representation of molecular and solid-state structure models"
+HOMEPAGE="http://www.krist.uni-freiburg.de/ki/Mitarbeiter/Keller/schakal.html"
+SRC_URI="http://www.krist.uni-freiburg.de/ki/Mitarbeiter/Keller/sch${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="|| ( ( x11-libs/libXaw
+ x11-terms/xterm
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+FORTRAN="gfortran"
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e "s:^\(MACHINE=\).*:\1LINUX:g" \
+ -e "s:^\(F77=\).*:\1${FORTRANC}:g" \
+ -e "s:^\(CC=\).*:\1$(tc-getCC):g" \
+ -e "s:^\(C_FLAGS = \).*:\1${CFLAGS} -DFILEPROMPT:g" \
+ ${S}/makefile.x
+ sed -i \
+ -e "s:^\(CC=\).*:\1$(tc-getCC):g" \
+ ${S}/makefile.fsb
+ sed -i \
+ -e 's~^jot.*~xterm -e ${EDITOR:-/bin/nano} $*~g' \
+ ${S}/editt.sh
+ epatch ${FILESDIR}/fix-xs-character-escapes.patch
+}
+
+src_compile() {
+ emake -f makefile.x || die "make.x failed"
+
+ # Do file selection box by hand -- taken from mfilepr script
+ mkdir file_selection_box
+ cd file_selection_box
+ mv ../file*.* .
+ mv ../makefile.fsb .
+ emake -f makefile.fsb || die "make.fsb failed"
+ cp fileprompt ../
+ cd ..
+
+}
+
+src_install() {
+ doexe ${S}/uschak ${S}/sch99x ${S}/fileprompt ${S}/printm
+
+ insinto /usr/lib/schakal
+ # create all the dat, scf, sif etc dirs with stuff in them
+}
+
+pkg_postinst() {
+ einfo "You may also wish to download the tutorial from"
+ einfo "http://www.krist.uni-freiburg.de/ki/Mitarbeiter/Keller/tutorial.pdf"
+}