aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-12-03 14:44:32 -0800
committerDonnie Berkholz <dberkholz@gentoo.org>2008-12-03 14:44:32 -0800
commit654c7de09613603d9863754f3f6c34cd05c59a79 (patch)
tree78fec64e3414c5261894dd51f13f55b316869652 /sci-biology
parentspasmoidal: another python package for multitasking. (diff)
downloaddberkholz-654c7de09613603d9863754f3f6c34cd05c59a79.tar.gz
dberkholz-654c7de09613603d9863754f3f6c34cd05c59a79.tar.bz2
dberkholz-654c7de09613603d9863754f3f6c34cd05c59a79.zip
jalview: nice gui for bioinformatics. ebuild still WIP.
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/jalview/jalview-2.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/jalview/jalview-2.3.ebuild b/sci-biology/jalview/jalview-2.3.ebuild
new file mode 100644
index 0000000..f3ee065
--- /dev/null
+++ b/sci-biology/jalview/jalview-2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit java-pkg-2
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://foo.bar.com/"
+SRC_URI="ftp://foo.bar.com/${P}.tar.gz"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND=">=virtual/jre-1.4
+ || ( dev-java/sun-jaf dev-java/gnu-jaf )
+ www-servers/axis
+ dev-java/castor
+ dev-java/commons-discovery
+ dev-java/commons-logging
+
+ sci-chemistry/jmol
+ dev-java/log4j
+ java-virtuals/javamail
+ || ( dev-java/jakarta-regexp dev-java/gnu-regexp )
+ dev-java/saaj
+
+ dev-java/wsdl4j
+ dev-java/xerces
+ "
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}