summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pigment-python/pigment-python-0.3.1.ebuild')
-rw-r--r--dev-python/pigment-python/pigment-python-0.3.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pigment-python/pigment-python-0.3.1.ebuild b/dev-python/pigment-python/pigment-python-0.3.1.ebuild
new file mode 100644
index 0000000..d228ae6
--- /dev/null
+++ b/dev-python/pigment-python/pigment-python-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2006-2007 BreakMyGentoo.org
+# Distributed under the terms of the GNU General Public License v2
+
+inherit gnome2 python
+
+DESCRIPTION="Python bindings for pigment"
+HOMEPAGE="http://elisa.fluendo.com/"
+SRC_URI="http://elisa.fluendo.com/static/download/pigment/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/pigment-0.3.3
+ >=dev-libs/glib-2.8
+ >=dev-python/pygobject-2.8
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10
+ >=x11-libs/gtk+-2
+ >=dev-lang/python-2.4"
+
+DEPEND="${DEPEND}"
+
+DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README TODO"
+
+MAKEOPTS="-j1"
+
+src_install() {
+ einstall || die
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}