summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-08-23 23:43:04 -0700
committerPatrick McLean <chutzpah@gentoo.org>2013-08-23 23:43:04 -0700
commite890f5e898620ef438fc33d3858103ceba74ce90 (patch)
treeb342b388736c8a1db0e186b0305f38dc8ed1e2a7
parentnet-im/pidgin: version bump (diff)
downloadchutzpah-e890f5e898620ef438fc33d3858103ceba74ce90.tar.gz
chutzpah-e890f5e898620ef438fc33d3858103ceba74ce90.tar.bz2
chutzpah-e890f5e898620ef438fc33d3858103ceba74ce90.zip
app-vim/hexman: new package, the hexman vim plugin
-rw-r--r--app-vim/hexman/Manifest2
-rw-r--r--app-vim/hexman/hexman-0.7.2.ebuild18
2 files changed, 20 insertions, 0 deletions
diff --git a/app-vim/hexman/Manifest b/app-vim/hexman/Manifest
new file mode 100644
index 0000000..7680cb3
--- /dev/null
+++ b/app-vim/hexman/Manifest
@@ -0,0 +1,2 @@
+DIST hexman-0.7.2.tar.gz 10079 SHA256 b22ed3e8649887050bda23a4e4276f7c768ff665b092035d93515c4a64beb701 SHA512 ebe0b23c254d504d2f17b677cd988ba9e79fb134153be775daf0dc2c306c93fda508eeb432ca522a53c449982a8ed0393d84450afc4d786c08a97dcfb15b05ea WHIRLPOOL 80a87acc6a7d289b4cc3405f311f0fcb8b261473b60a671f849469d3bc6f2ada70c7caa76e8c9107dd4bc3b83946a0c5213fd6e65fc089660d5bdb7195185f6d
+EBUILD hexman-0.7.2.ebuild 578 SHA256 a002ba74a6bac72897ee1a7411a0d91fd40ef545fdad9fb76b56cb5257b6bebf SHA512 49ff1519f0446e4956f4138bac5b56c77c634eb19fefd40ff3e7cb216c9684858d8ec469270595c72da1de77ef1d9f755e7ce95ee615891688d5383c3ccb8f2b WHIRLPOOL fad842e34dda6498c998787084857ae5413cfc4e6ef0dffa320f7a941e22a1ec120bc5d4e9ed39309c34dcec2f63dfbf2c934f74a60455a1b41b18f03f2469e1
diff --git a/app-vim/hexman/hexman-0.7.2.ebuild b/app-vim/hexman/hexman-0.7.2.ebuild
new file mode 100644
index 0000000..e2ef6aa
--- /dev/null
+++ b/app-vim/hexman/hexman-0.7.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/undotree/undotree-4.3.ebuild,v 1.1 2013/02/21 07:39:35 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+EXTRA_VER="d332b71"
+
+DESCRIPTION="vim plugin: Simpler Hex viewing and editing"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=666"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/vim-scripts-${MY_PN}-${EXTRA_VER}"