summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2012-05-30 19:51:19 -0700
committerPatrick McLean <chutzpah@gentoo.org>2012-05-30 19:51:19 -0700
commit41a7d8b8992ccdb5767c9db105830222faae3bac (patch)
tree3a8bf929997e9424df9eb9b78c261f436bf2e90c
parentmanifest update (diff)
downloadchutzpah-41a7d8b8992ccdb5767c9db105830222faae3bac.tar.gz
chutzpah-41a7d8b8992ccdb5767c9db105830222faae3bac.tar.bz2
chutzpah-41a7d8b8992ccdb5767c9db105830222faae3bac.zip
add pidgin-2.10.4
-rw-r--r--net-im/pidgin/Manifest2
-rw-r--r--net-im/pidgin/pidgin-2.10.4.ebuild235
2 files changed, 237 insertions, 0 deletions
diff --git a/net-im/pidgin/Manifest b/net-im/pidgin/Manifest
index ef5db7b..0fce54d 100644
--- a/net-im/pidgin/Manifest
+++ b/net-im/pidgin/Manifest
@@ -4,5 +4,7 @@ AUX pidgin-2.10.0-utf8-validation.patch 908 RMD160 0f98c6dd6cd9c63b3d61c85a9f18a
AUX pidgin-gnome-keyring-2.patch 7680 RMD160 e9f14a4b46aad4e7361113a33fd5e07085bbd978 SHA1 edeca69cb6980f7b5b9ce61a83f7e0ac227c779a SHA256 aae63e57a7dc50b1232a606f7824dc655f561ed5ff7ef36607e18a18c98aa221
DIST pidgin-2.10.1.tar.bz2 9961580 RMD160 f73c5540fd01f62ae2a0ae236436f06770a896ef SHA1 045ed0fd7dfedada6e082e7a4564648b55950064 SHA256 2f28bddc5edcd714d607d74126c8958ae7c258602b3929e3e6e783d3cb1beac8
DIST pidgin-2.10.3.tar.bz2 9970676 RMD160 10af4caee9f22a251f867e3befebcc659e2b42f3 SHA1 7dfeabdb1ade4311c91ac9c9f988276f67ead6ee SHA256 0f67d96231fea3945c2735e6a3b4bd92590ef489fa1511fa69aa6a543cb4168b
+DIST pidgin-2.10.4.tar.bz2 9970850 RMD160 5193a7f5dbd122198d474bd7e11dc9bf307befb3 SHA1 f9ce34e69f97bcd1bb216aefb6d687b5b47f0796 SHA256 8fbef835c8dfa2281532ad7064d664477d72015d6dcd4345362dcfe658aaee0e
EBUILD pidgin-2.10.1.ebuild 7147 RMD160 7ab996af7067ab7764a9944c2903a98e4d3816c1 SHA1 cfc748af3d532119cdb8dcd6271045a59b7dbbd7 SHA256 814bfb9f568980ebc848ad5fa8b31b24c71b2d2e6e19b5c4b81f22208257781d
EBUILD pidgin-2.10.3.ebuild 7084 RMD160 b37994990a0bb3ca7f7ed21d56b762f83da57aa9 SHA1 59a81775ed54ca936967ace0a9eb2ef3ae427081 SHA256 60ce9d9b210db5207340afaf7a9a0b583c9f8297d8fa41f42759c57ac510592f
+EBUILD pidgin-2.10.4.ebuild 7165 RMD160 f36325853913962e2b2e742cf24ff58c89290ed5 SHA1 26aaf233681722304c346185fc32960dfcb1cee1 SHA256 13757567ede98c20c141c5b0f7dacd2bbcda0ae9c90c7e86fbb40bafcf5f0656
diff --git a/net-im/pidgin/pidgin-2.10.4.ebuild b/net-im/pidgin/pidgin-2.10.4.ebuild
new file mode 100644
index 0000000..13cb042
--- /dev/null
+++ b/net-im/pidgin/pidgin-2.10.4.ebuild
@@ -0,0 +1,235 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.4.ebuild,v 1.4 2012/05/29 12:07:14 ago Exp $
+
+EAPI=4
+
+GENTOO_DEPEND_ON_PERL=no
+inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2 python
+inherit autotools
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://pidgin.im/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="dbus debug doc eds gadu gnutls +gstreamer +gtk idn meanwhile"
+IUSE+=" networkmanager nls perl silc tcl tk spell sasl ncurses"
+IUSE+=" groupwise prediction python +xscreensaver zephyr zeroconf" # mono"
+IUSE+=" aqua"
+IUSE+=" gnome-keyring"
+
+# dbus requires python to generate C code for dbus bindings (thus DEPEND only).
+# finch uses libgnt that links with libpython - {R,}DEPEND. But still there is
+# no way to build dbus and avoid libgnt linkage with python. If you want this
+# send patch upstream.
+# purple-url-handler and purple-remote require dbus-python thus in reality we
+# rdepend on python if dbus enabled. But it is possible to separate this dep.
+RDEPEND="
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2.6.18
+ ncurses? ( sys-libs/ncurses[unicode]
+ dbus? ( <dev-lang/python-3 )
+ python? ( <dev-lang/python-3 ) )
+ gtk? (
+ >=x11-libs/gtk+-2.10:2[aqua=]
+ x11-libs/libSM
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ spell? ( >=app-text/gtkspell-2.0.2:2 )
+ eds? ( gnome-extra/evolution-data-server )
+ prediction? ( >=dev-db/sqlite-3.3:3 ) )
+ gstreamer? ( =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ || ( net-libs/farstream net-libs/farsight2 )
+ media-plugins/gst-plugins-meta
+ media-plugins/gst-plugins-gconf )
+ zeroconf? ( net-dns/avahi[dbus] )
+ dbus? ( >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-0.90
+ dev-python/dbus-python )
+ perl? ( >=dev-lang/perl-5.8.2-r1[-build] )
+ gadu? ( || ( >=net-libs/libgadu-1.11.0[ssl,gnutls]
+ >=net-libs/libgadu-1.11.0[-ssl] ) )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ meanwhile? ( net-libs/meanwhile )
+ silc? ( >=net-im/silc-toolkit-1.0.1 )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ networkmanager? ( net-misc/networkmanager )
+ idn? ( net-dns/libidn )
+ !<x11-plugins/pidgin-facebookchat-1.69-r1"
+ # Mono support crashes pidgin
+ #mono? ( dev-lang/mono )"
+
+# We want nls in case gtk is enabled, bug #
+NLS_DEPEND=">=dev-util/intltool-0.41.1 sys-devel/gettext"
+
+DEPEND="$RDEPEND
+ dev-lang/perl
+ dev-perl/XML-Parser
+ virtual/pkgconfig
+ gtk? ( x11-proto/scrnsaverproto
+ ${NLS_DEPEND} )
+ dbus? ( <dev-lang/python-3 )
+ doc? ( app-doc/doxygen )
+ !gtk? ( nls? ( ${NLS_DEPEND} ) )"
+
+DOCS="AUTHORS HACKING NEWS README ChangeLog"
+
+# Enable Default protocols
+DYNAMIC_PRPLS="irc,jabber,oscar,yahoo,simple,msn,myspace"
+
+# List of plugins
+# app-accessibility/pidgin-festival
+# net-im/librvp
+# x11-plugins/guifications
+# x11-plugins/msn-pecan
+# x11-plugins/pidgin-encryption
+# x11-plugins/pidgin-extprefs
+# x11-plugins/pidgin-hotkeys
+# x11-plugins/pidgin-latex
+# x11-plugins/pidgintex
+# x11-plugins/pidgin-libnotify
+# x11-plugins/pidgin-mbpurple
+# x11-plugins/pidgin-bot-sentry
+# x11-plugins/pidgin-otr
+# x11-plugins/pidgin-rhythmbox
+# x11-plugins/purple-plugin_pack
+# x11-themes/pidgin-smileys
+# x11-plugins/pidgin-knotify
+# Plugins in Sunrise:
+# x11-plugins/pidgin-audacious-remote
+# x11-plugins/pidgin-autoanswer
+# x11-plugins/pidgin-birthday-reminder
+# x11-plugins/pidgin-blinklight
+# x11-plugins/pidgin-convreverse
+# x11-plugins/pidgin-embeddedvideo
+# x11-plugins/pidgin-extended-blist-sort
+# x11-plugins/pidgin-gfire
+# x11-plugins/pidgin-lastfm
+# x11-plugins/pidgin-sendscreenshot
+# x11-plugins/pidgimpd
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ elog "You did not pick the ncurses or gtk use flags, only libpurple"
+ elog "will be built."
+ fi
+ if use dbus || { use ncurses && use python; }; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ # dbus is enabled, no way to disable linkage with python => python is enabled
+ #REQUIRED_USE="gtk? ( nls ) dbus? ( python )"
+ if use gtk && ! use nls; then
+ ewarn "gtk build => nls is enabled!"
+ fi
+ if use dbus && ! use python; then
+ elog "dbus is enabled, no way to disable linkage with python => python is enabled"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.10.0-gold.patch"
+
+ epatch "${FILESDIR}"/${PN}-gnome-keyring-2.patch
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ local myconf
+
+ if use gadu; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},gg"
+ myconf="${myconf} --with-gadu-includes=."
+ myconf="${myconf} --with-gadu-libs=."
+ fi
+
+ use silc && DYNAMIC_PRPLS+=",silc"
+ use meanwhile && DYNAMIC_PRPLS+=",sametime"
+ use zeroconf && DYNAMIC_PRPLS+=",bonjour"
+ use groupwise && DYNAMIC_PRPLS+=",novell"
+ use zephyr && DYNAMIC_PRPLS+=",zephyr"
+
+ if use gnutls; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf+=" --enable-nss=no --enable-gnutls=yes"
+ myconf+=" --with-gnutls-includes=${EPREFIX}/usr/include/gnutls"
+ myconf+=" --with-gnutls-libs=${EPREFIX}/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf+=" --enable-gnutls=no --enable-nss=yes"
+ fi
+
+ if use dbus || { use ncurses && use python; }; then
+ myconf+=" --with-python=$(PYTHON)"
+ else
+ myconf+=" --without-python"
+ fi
+
+ econf \
+ --disable-silent-rules \
+ $(use_enable ncurses consoleui) \
+ $(use_enable gtk gtkui) \
+ $(use_enable gtk sm) \
+ $(use gtk || use_enable nls) \
+ $(use gtk && echo "--enable-nls") \
+ $(use gtk && use_enable xscreensaver screensaver) \
+ $(use gtk && use_enable prediction cap) \
+ $(use gtk && use_enable eds gevolution) \
+ $(use gtk && use_enable spell gtkspell) \
+ $(use_enable perl) \
+ $(use_enable tk) \
+ $(use_enable tcl) \
+ $(use_enable debug) \
+ $(use_enable dbus) \
+ $(use_enable meanwhile) \
+ $(use_enable gstreamer) \
+ $(use_enable gnome-keyring) \
+ $(use_enable gstreamer farstream) \
+ $(use_enable gstreamer vv) \
+ $(use_enable sasl cyrus-sasl ) \
+ $(use_enable doc doxygen) \
+ $(use_enable networkmanager nm) \
+ $(use_enable zeroconf avahi) \
+ $(use_enable idn) \
+ --with-system-ssl-certs="${EPREFIX}/etc/ssl/certs/" \
+ --with-dynamic-prpls="${DYNAMIC_PRPLS}" \
+ --disable-mono \
+ --x-includes="${EPREFIX}"/usr/include/X11 \
+ ${myconf}
+ #$(use_enable mono) \
+}
+
+src_install() {
+ gnome2_src_install
+ if use gtk; then
+ # Fix tray pathes for kde-3.5, e16 (x11-wm/enlightenment) and other
+ # implementations that are not complient with new hicolor theme yet, #323355
+ local pixmapdir
+ for d in 16 22 32 48; do
+ pixmapdir=${ED}/usr/share/pixmaps/pidgin/tray/hicolor/${d}x${d}/actions
+ mkdir "${pixmapdir}" || die
+ pushd "${pixmapdir}" >/dev/null || die
+ for f in ../status/*; do
+ ln -s ${f} || die
+ done
+ popd >/dev/null
+ done
+ fi
+ use perl && fixlocalpod
+
+ dodoc finch/plugins/pietray.py
+ docompress -x /usr/share/doc/${PF}/pietray.py
+
+ find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}