summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2019-11-03 00:41:36 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2019-11-03 01:06:05 +0300
commit1318c7ad5574911986150f1bf7b4e1410ab33961 (patch)
tree829e6d8199179726733cc81428881574bf15060b
parentmplayer: remove obsolete ivtv support (diff)
downloadbircoph-1318c7ad5574911986150f1bf7b4e1410ab33961.tar.gz
bircoph-1318c7ad5574911986150f1bf7b4e1410ab33961.tar.bz2
bircoph-1318c7ad5574911986150f1bf7b4e1410ab33961.zip
mplayer: add yuv4mpeg support
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--media-video/mplayer/metadata.xml1
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild5
2 files changed, 3 insertions, 3 deletions
diff --git a/media-video/mplayer/metadata.xml b/media-video/mplayer/metadata.xml
index b7639f1..eb5e68a 100644
--- a/media-video/mplayer/metadata.xml
+++ b/media-video/mplayer/metadata.xml
@@ -52,6 +52,7 @@
<flag name="win32codecs">Support for binary win32 codecs</flag>
<flag name="xanim">Enables support for xanim based codecs</flag>
<flag name="xvmc">Enables X-Video Motion Compensation support</flag>
+ <flag name="yuv4mpeg">Enables yuv4mpeg video output</flag>
<flag name="zoran">Enables ZR360[56]7/ZR36060 video output</flag>
</use>
</pkgmetadata>
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 223173a..5001b09 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -15,8 +15,7 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
+network nut openal +opengl opus +osdmenu oss png pnm pulseaudio pvr +quicktime
radio +rar +real +rtc rtmp samba +shm +schroedinger sdl +speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3 svga svga-helper
tga +theora tivo +tremor +truetype toolame +twolame +unicode v4l vdpau vidix
-+vorbis vpx win32codecs +X +x264 xanim xinerama +xscreensaver +xv +xvid xvmc
-zoran"
++vorbis vpx win32codecs +X +x264 xanim xinerama +xscreensaver +xv +xvid xvmc yuv4mpeg zoran"
EGIT_REPO_URI="git://git.videolan.org/ffmpeg.git"
EGIT_PROJECT="ffmpeg" # git eclass sets it to PN otherwise
@@ -419,7 +418,7 @@ src_configure() {
################
# Video Output #
################
- uses="directfb md5sum sdl"
+ uses="directfb md5sum sdl yuv4mpeg"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done