summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug/werkzeug-0.15.1.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-0.15.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/werkzeug/werkzeug-0.15.1.ebuild b/dev-python/werkzeug/werkzeug-0.15.1.ebuild
deleted file mode 100644
index 4573cc4..0000000
--- a/dev-python/werkzeug/werkzeug-0.15.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="Werkzeug"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- )"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
- py.test -v tests || die "Tests failed under ${EPYTHON}"
-}