summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/ChangeLog8
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.7.2.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/xfce-base/libxfce4ui/ChangeLog b/xfce-base/libxfce4ui/ChangeLog
index fe6e164603ca..1116ff5d45ab 100644
--- a/xfce-base/libxfce4ui/ChangeLog
+++ b/xfce-base/libxfce4ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfce4ui
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.9 2010/03/31 12:14:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.10 2010/04/19 14:05:25 darkside Exp $
+
+*libxfce4ui-4.7.2 (19 Apr 2010)
+
+ 19 Apr 2010; Jeremy Olexa <darkside@gentoo.org> +libxfce4ui-4.7.2.ebuild:
+ Version bump, bug fix release.
+ http://releases.xfce.org/feeds/project/libxfce4ui
31 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
libxfce4ui-4.7.1.ebuild:
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.7.2.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.7.2.ebuild
new file mode 100644
index 000000000000..f09af7f794e1
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.7.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/libxfce4ui-4.7.2.ebuild,v 1.1 2010/04/19 14:05:25 darkside Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Unified widgets library for Xfce4, a libxfcegui4 replacement"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug glade startup-notification"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=dev-libs/glib-2.16:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/xfconf-4.6
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ dev-lang/perl"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ $(xfconf_use_debug)
+ --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
+ DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+}