summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmbattery')
-rw-r--r--x11-plugins/wmbattery/ChangeLog10
-rw-r--r--x11-plugins/wmbattery/wmbattery-2.19-r1.ebuild41
-rw-r--r--x11-plugins/wmbattery/wmbattery-2.42.ebuild33
3 files changed, 41 insertions, 43 deletions
diff --git a/x11-plugins/wmbattery/ChangeLog b/x11-plugins/wmbattery/ChangeLog
index 9b548f5ef7c4..98631a0c53a5 100644
--- a/x11-plugins/wmbattery/ChangeLog
+++ b/x11-plugins/wmbattery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmbattery
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbattery/ChangeLog,v 1.23 2012/09/25 14:08:40 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbattery/ChangeLog,v 1.24 2014/02/11 09:42:47 voyageur Exp $
+
+*wmbattery-2.42 (11 Feb 2014)
+
+ 11 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ -wmbattery-2.19-r1.ebuild, +wmbattery-2.42.ebuild:
+ Version bump, adds upower support
*wmbattery-2.41 (25 Sep 2012)
diff --git a/x11-plugins/wmbattery/wmbattery-2.19-r1.ebuild b/x11-plugins/wmbattery/wmbattery-2.19-r1.ebuild
deleted file mode 100644
index e12bfb0e5baf..000000000000
--- a/x11-plugins/wmbattery/wmbattery-2.19-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbattery/wmbattery-2.19-r1.ebuild,v 1.8 2012/07/08 15:24:35 jer Exp $
-
-inherit eutils
-
-IUSE=""
-
-S=${WORKDIR}/${PN}
-
-DESCRIPTION="A dockable app to report APM battery stats."
-SRC_URI="http://kitenet.net/programs/wmbattery/${P/-/_}.tar.gz"
-HOMEPAGE="http://joeyh.name/code/wmbattery/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 amd64 -sparc ~ppc"
-
-RDEPEND="sys-apps/apmd
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXt
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-proto/xextproto"
-
-src_compile() {
- econf || die "Configuration failed"
- emake icondir="/usr/share/pixmaps/wmbattery" || die "Compilation failed"
-}
-
-src_install () {
- dobin wmbattery
- dodoc README TODO
-
- mv wmbattery.1x wmbattery.1
- doman wmbattery.1
-
- insinto /usr/share/pixmaps/wmbattery
- doins *.xpm
-}
diff --git a/x11-plugins/wmbattery/wmbattery-2.42.ebuild b/x11-plugins/wmbattery/wmbattery-2.42.ebuild
new file mode 100644
index 000000000000..9983d5ab6859
--- /dev/null
+++ b/x11-plugins/wmbattery/wmbattery-2.42.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbattery/wmbattery-2.42.ebuild,v 1.1 2014/02/11 09:42:47 voyageur Exp $
+
+EAPI=5
+inherit autotools
+
+DESCRIPTION="A dockable app to report APM, ACPI, or SPIC battery status"
+HOMEPAGE="http://joeyh.name/code/wmbattery/"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/apmd
+ sys-power/upower
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( README TODO )
+
+src_prepare() {
+ sed -i \
+ -e '/^icondir/s:icons:pixmaps:' \
+ autoconf/makeinfo.in || die
+
+ eautoconf
+}