summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xmobar/xmobar-0.9.ebuild')
-rw-r--r--x11-misc/xmobar/xmobar-0.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/xmobar/xmobar-0.9.ebuild b/x11-misc/xmobar/xmobar-0.9.ebuild
new file mode 100644
index 000000000000..c185c4996238
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/xmobar-0.9.ebuild,v 1.1 2008/09/24 06:11:46 kolmodin Exp $
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://code.haskell.org/~arossato/xmobar"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/cabal-1.2
+ >=dev-haskell/x11-1.3.0
+ dev-haskell/mtl
+ dev-haskell/parsec
+ dev-haskell/filepath
+ dev-haskell/stm"
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--flags=-with_xft --flags=-with_utf8"
+ cabal_src_compile
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc xmobar.config-sample README
+}