summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild')
-rw-r--r--x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild b/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild
index 0e1516e8e846..7b220de649c5 100644
--- a/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild
+++ b/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild,v 1.1 2003/06/25 06:06:08 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild,v 1.2 2003/06/25 18:37:12 bcowan Exp $
-IUSE=""
+IUSE="X"
S=${WORKDIR}/${P}
DESCRIPTION="Xfce4 desktop"
@@ -21,6 +21,16 @@ DEPEND=">=x11-libs/gtk+-2.0.6
=x11-libs/libxfce4mcs-3.91.0
=x11-misc/xfce-mcs-manager-3.91.0"
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
src_install() {
make DESTDIR=${D} install || die