summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbcd/bbcd-0.3.1-r1.ebuild')
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
index 8de6db37d226..1644aaebd7e9 100644
--- a/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
+++ b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild,v 1.10 2011/04/16 17:23:21 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild,v 1.11 2012/01/29 03:02:06 xmw Exp $
+
+EAPI="4"
inherit eutils
@@ -12,19 +14,17 @@ SLOT="0"
KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
IUSE=""
-DEPEND="media-libs/libcdaudio"
+RDEPEND="media-libs/libcdaudio
+ x11-libs/libX11"
-src_unpack() {
- unpack ${A}
+src_prepare() {
epatch "${FILESDIR}"/${P}_${PV}a.diff
epatch "${FILESDIR}"/${P}-gcc3.3.patch
epatch "${FILESDIR}"/${P}-gcc4.3.patch
}
src_install () {
- make \
- DESTDIR="${D}" \
- install || die
- rm -rf "${D}"/usr/doc
+ emake DESTDIR="${D}" install
+ rm -rf "${D}"/usr/doc || die
dodoc AUTHORS BUGS ChangeLog NEWS README
}