summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/freshplayerplugin/ChangeLog11
-rw-r--r--www-plugins/freshplayerplugin/files/with-pulseaudio-cmake.patch27
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.2.3.ebuild59
-rw-r--r--www-plugins/freshplayerplugin/metadata.xml8
4 files changed, 105 insertions, 0 deletions
diff --git a/www-plugins/freshplayerplugin/ChangeLog b/www-plugins/freshplayerplugin/ChangeLog
new file mode 100644
index 000000000000..2df4ad250cdf
--- /dev/null
+++ b/www-plugins/freshplayerplugin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-plugins/freshplayerplugin
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/freshplayerplugin/ChangeLog,v 1.1 2015/03/11 01:13:44 grknight Exp $
+
+*freshplayerplugin-0.2.3 (11 Mar 2015)
+
+ 11 Mar 2015; Brian Evans <grknight@gentoo.org>
+ +files/with-pulseaudio-cmake.patch, +freshplayerplugin-0.2.3.ebuild,
+ +metadata.xml:
+ Initial commit. Ebuild written by me with input from bug 511512 and BtbN on
+ IRC
diff --git a/www-plugins/freshplayerplugin/files/with-pulseaudio-cmake.patch b/www-plugins/freshplayerplugin/files/with-pulseaudio-cmake.patch
new file mode 100644
index 000000000000..22bad5728292
--- /dev/null
+++ b/www-plugins/freshplayerplugin/files/with-pulseaudio-cmake.patch
@@ -0,0 +1,27 @@
+diff -aurN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2015-02-15 17:05:40.000000000 -0500
++++ b/CMakeLists.txt 2015-03-10 19:33:48.519110012 -0400
+@@ -45,12 +45,18 @@
+ openssl
+ REQUIRED)
+
+-pkg_check_modules(PULSEAUDIO libpulse)
++OPTION(WITH_PULSEAUDIO "Enable pulseaudio support" ON)
+
+-if (${PULSEAUDIO_FOUND})
+- add_definitions(-DHAVE_PULSEAUDIO=1)
+- set(HAVE_PULSEAUDIO 1)
+-endif()
++IF(WITH_PULSEAUDIO)
++ pkg_check_modules(PULSEAUDIO libpulse)
++
++ if (${PULSEAUDIO_FOUND})
++ add_definitions(-DHAVE_PULSEAUDIO=1)
++ set(HAVE_PULSEAUDIO 1)
++ else()
++ MESSAGE(FATAL_ERROR "PulseAudio not found")
++ endif()
++ENDIF(WITH_PULSEAUDIO)
+
+ include_directories(${REQ_INCLUDE_DIRS})
+ add_definitions(${REQ_CFLAGS_OTHER})
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.2.3.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.2.3.ebuild
new file mode 100644
index 000000000000..f3ddc5e8fdbd
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.2.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/freshplayerplugin/freshplayerplugin-0.2.3.ebuild,v 1.1 2015/03/11 01:13:44 grknight Exp $
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.8"
+
+inherit cmake-utils multilib
+
+LICENSE="MIT"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+DESCRIPTION="PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT=0
+IUSE="pulseaudio"
+
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-libs/glib:2=
+ dev-libs/libconfig:=
+ dev-libs/libevent:=[threads]
+ dev-libs/openssl:0=
+ media-libs/alsa-lib:=
+ media-libs/freetype:2=
+ media-libs/mesa:=[egl,gles2]
+ x11-libs/gtk+:2=
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/pango:=[X]
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+DEPEND="${CDEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+ "
+RDEPEND="${CDEPEND}
+ || (
+ www-plugins/chrome-binary-plugins[flash]
+ www-client/google-chrome
+ www-client/google-chrome-beta
+ www-client/google-chrome-unstable
+ )
+ "
+
+PATCHES=( "${FILESDIR}/with-pulseaudio-cmake.patch" )
+
+src_configure() {
+ mycmakeargs=( $(cmake-utils_use_with pulseaudio PULSEAUDIO) )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dodoc ChangeLog data/freshwrapper.conf.example README.md
+ exeinto /usr/$(get_libdir)/nsbrowser/plugins
+ doexe "${BUILD_DIR}/libfreshwrapper-pepperflash.so"
+}
diff --git a/www-plugins/freshplayerplugin/metadata.xml b/www-plugins/freshplayerplugin/metadata.xml
new file mode 100644
index 000000000000..994d2278b194
--- /dev/null
+++ b/www-plugins/freshplayerplugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>grknight@gentoo.org</email>
+ <name>Brian Evans</name>
+</maintainer>
+</pkgmetadata>