summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/m4/m4-1.4.4.ebuild')
-rw-r--r--sys-devel/m4/m4-1.4.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-devel/m4/m4-1.4.4.ebuild b/sys-devel/m4/m4-1.4.4.ebuild
new file mode 100644
index 000000000000..ff6b2b12fdb8
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.4.ebuild,v 1.1 2005/10/21 12:42:27 agriffis Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.seindal.dk/gnu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.4.3-pointer.patch
+}
+
+src_compile() {
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ econf \
+ $(use_enable nls) \
+ --enable-changeword \
+ ${myconf} \
+ || die
+ emake AR="$(tc-getAR)" || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc BACKLOG ChangeLog NEWS README* THANKS TODO
+}