summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gettext/gettext-0.14.2.ebuild')
-rw-r--r--sys-devel/gettext/gettext-0.14.2.ebuild37
1 files changed, 10 insertions, 27 deletions
diff --git a/sys-devel/gettext/gettext-0.14.2.ebuild b/sys-devel/gettext/gettext-0.14.2.ebuild
index f52a0019bdbe..5427fa4cc672 100644
--- a/sys-devel/gettext/gettext-0.14.2.ebuild
+++ b/sys-devel/gettext/gettext-0.14.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.2.ebuild,v 1.8 2006/03/09 23:49:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.2.ebuild,v 1.9 2007/01/23 19:46:08 grobian Exp $
inherit flag-o-matic eutils toolchain-funcs mono libtool elisp-common
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="emacs nls"
DEPEND=""
@@ -42,12 +42,7 @@ src_unpack() {
gettext-tools/examples/installpaths.in \
|| die "sed docdir"
- if use ppc-macos ; then
- glibtoolize
- append-flags -bind_at_load
- else
- elibtoolize --reverse-deps
- fi
+ elibtoolize --reverse-deps
}
src_compile() {
@@ -73,31 +68,19 @@ src_install() {
doexe gettext-tools/misc/gettextize || die "doexe"
# remove stuff that glibc handles
- if ! use ppc-macos; then
- # Mac OS X does not provide these files.
- rm -f ${D}/usr/include/libintl.h
- rm -f ${D}/usr/$(get_libdir)/libintl.*
- fi
+ rm -f ${D}/usr/include/libintl.h
+ rm -f ${D}/usr/$(get_libdir)/libintl.*
rm -rf ${D}/usr/share/locale/locale.alias
# older gettext's sometimes installed libintl ...
# need to keep the linked version or the system
# could die (things like sed link against it :/)
- if use ppc-macos; then
- rm -f ${D}/usr/lib/charset.alias
- if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.2.dylib ] ; then
- cp -pPR ${ROOT}/usr/$(get_libdir)/libintl.2.dylib ${D}/usr/$(get_libdir)/
- touch ${D}/usr/$(get_libdir)/libintl.2.dylib
- fi
- else
- if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.so.2 ] ; then
- cp -pPR ${ROOT}/usr/$(get_libdir)/libintl.so.2* ${D}/usr/$(get_libdir)/
- touch ${D}/usr/$(get_libdir)/libintl.so.2*
- fi
+ if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.so.2 ] ; then
+ cp -pPR ${ROOT}/usr/$(get_libdir)/libintl.so.2* ${D}/usr/$(get_libdir)/
+ touch ${D}/usr/$(get_libdir)/libintl.so.2*
fi
- if [ -d ${D}/usr/doc/gettext ]
- then
+ if [ -d ${D}/usr/doc/gettext ] ; then
mv ${D}/usr/doc/gettext ${D}/usr/share/doc/${PF}/html
rm -rf ${D}/usr/doc
fi