summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/openmosixview/openmosixview-1.5.ebuild')
-rw-r--r--sys-cluster/openmosixview/openmosixview-1.5.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-cluster/openmosixview/openmosixview-1.5.ebuild b/sys-cluster/openmosixview/openmosixview-1.5.ebuild
index e1da0079eeab..898063663579 100644
--- a/sys-cluster/openmosixview/openmosixview-1.5.ebuild
+++ b/sys-cluster/openmosixview/openmosixview-1.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosixview/openmosixview-1.5.ebuild,v 1.4 2005/01/18 16:40:53 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosixview/openmosixview-1.5.ebuild,v 1.5 2005/04/15 16:16:53 xmerlin Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
S=${WORKDIR}/openmosixview-${PV}
DESCRIPTION="cluster-management GUI for OpenMosix"
@@ -22,6 +22,11 @@ src_unpack() {
cd ${WORKDIR}
unpack openmosixview-${PV}.tar.gz
+ epatch ${FILESDIR}/${P}-logdirectory.diff || die
+ epatch ${FILESDIR}/${P}-nonodestmp.diff || die
+ epatch ${FILESDIR}/${P}-usesyslog.diff || die
+ epatch ${FILESDIR}/${P}-typos.patch || die
+
cat > configuration << EOF
# test which version of qt is installed
if [ -d /usr/qt/3 ]; then
@@ -44,6 +49,8 @@ src_install() {
dodoc COPYING README
+ keepdir /var/lib/openmosixview
+
exeinto /etc/init.d
rm ${D}/etc/init.d/openmosixcollector
newexe ${FILESDIR}/openmosixcollector.init openmosixcollector