summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/spindown/ChangeLog11
-rw-r--r--sys-block/spindown/metadata.xml10
-rw-r--r--sys-block/spindown/spindown-0.2.2.ebuild46
3 files changed, 67 insertions, 0 deletions
diff --git a/sys-block/spindown/ChangeLog b/sys-block/spindown/ChangeLog
new file mode 100644
index 000000000000..964d4d2880b6
--- /dev/null
+++ b/sys-block/spindown/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-block/spindown
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/ChangeLog,v 1.1 2008/11/21 18:20:42 wschlich Exp $
+
+*spindown-0.2.2 (21 Nov 2008)
+
+ 21 Nov 2008; Wolfram Schlich <wschlich@gentoo.org>
+ +files/spindown-0.2.2-CFLAGS.patch, +files/spindownd.confd,
+ +files/spindownd.initd, +metadata.xml, +spindown-0.2.2.ebuild:
+ initial import
+
diff --git a/sys-block/spindown/metadata.xml b/sys-block/spindown/metadata.xml
new file mode 100644
index 000000000000..a7162e9b7104
--- /dev/null
+++ b/sys-block/spindown/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-block/spindown/spindown-0.2.2.ebuild b/sys-block/spindown/spindown-0.2.2.ebuild
new file mode 100644
index 000000000000..687860672887
--- /dev/null
+++ b/sys-block/spindown/spindown-0.2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/spindown-0.2.2.ebuild,v 1.1 2008/11/21 18:20:42 wschlich Exp $
+
+inherit eutils
+
+DESCRIPTION="Spindown is a daemon that can spin down idle disks"
+HOMEPAGE="http://code.google.com/p/spindown"
+SRC_URI="http://spindown.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ sys-apps/sg3_utils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-CFLAGS.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /etc
+ newins spindown.conf.example spindown.conf
+ newinitd "${FILESDIR}"/spindownd.initd spindownd
+ newconfd "${FILESDIR}"/spindownd.confd spindownd
+ dosbin spindownd
+ dodoc CHANGELOG README TODO spindown.conf.example
+}
+
+pkg_postinst() {
+ elog "Before starting spindownd the first time"
+ elog "you should modify /etc/spindown.conf"
+ elog
+ elog "To start spindownd by default"
+ elog "you should add it to the default runlevel:"
+ elog " rc-update add spindown default"
+}