summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/gato/gato-0.99c.ebuild')
-rw-r--r--sci-misc/gato/gato-0.99c.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/sci-misc/gato/gato-0.99c.ebuild b/sci-misc/gato/gato-0.99c.ebuild
index 72d52f535414..3797259fb9b9 100644
--- a/sci-misc/gato/gato-0.99c.ebuild
+++ b/sci-misc/gato/gato-0.99c.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.3 2008/01/29 15:08:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.4 2008/10/27 12:06:52 bicatali Exp $
+EAPI=2
inherit python eutils multilib
MY_PN="Gato"
@@ -16,19 +17,13 @@ SRC_URI="http://gato.sourceforge.net/Download/${MY_PN}-${MY_PV}.tar.gz
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE="doc"
+DEPEND="dev-lang/python[tk]"
S="${WORKDIR}"/${MY_PN}
-pkg_setup() {
- python_tkinter_exists
-}
-
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
# convert to python >=2.4
epatch "${FILESDIR}"/${P}-python.patch
-
# change TKinter call to avoid crashing of X
sed -i \
-e 's:self.overrideredirect(1):self.overrideredirect(0):' \