summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave-forge')
-rw-r--r--sci-mathematics/octave-forge/octave-forge-2004.11.16-r1.ebuild4
-rw-r--r--sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild7
2 files changed, 6 insertions, 5 deletions
diff --git a/sci-mathematics/octave-forge/octave-forge-2004.11.16-r1.ebuild b/sci-mathematics/octave-forge/octave-forge-2004.11.16-r1.ebuild
index d961c60546b0..918570f84746 100644
--- a/sci-mathematics/octave-forge/octave-forge-2004.11.16-r1.ebuild
+++ b/sci-mathematics/octave-forge/octave-forge-2004.11.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/octave-forge-2004.11.16-r1.ebuild,v 1.2 2005/06/26 02:13:44 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/octave-forge-2004.11.16-r1.ebuild,v 1.3 2005/08/21 18:56:45 ribosome Exp $
inherit eutils
@@ -22,7 +22,7 @@ DEPEND=">=sci-mathematics/octave-2.1.62
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${PV}.patch
+ epatch ${FILESDIR}/${PN}-mex.patch
# make it compile when X isn't installed. The source file there really
# doesn't need X at all.
diff --git a/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild b/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild
index aafc0d6b382c..4827fa7c50fa 100644
--- a/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild
+++ b/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild,v 1.2 2005/08/20 19:05:36 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild,v 1.3 2005/08/21 18:56:45 ribosome Exp $
inherit eutils
@@ -22,7 +22,8 @@ DEPEND="=sci-mathematics/octave-2.1.69*
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/2004.11.16.patch
+ epatch ${FILESDIR}/${PN}-mex.patch
+ epatch ${FILESDIR}/${PN}-randmtzig.patch
# make it compile when X isn't installed. The source file there really
# doesn't need X at all.
@@ -31,7 +32,7 @@ src_unpack() {
}
src_compile() {
- econf || die "econf failed"
+ econf --enable-shared || die "econf failed"
# this must be done before the *PATH variables are changed
cd extra/graceplot && make grace_octave_path.m