summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/jags')
-rw-r--r--sci-mathematics/jags/ChangeLog7
-rw-r--r--sci-mathematics/jags/jags-3.4.0.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sci-mathematics/jags/ChangeLog b/sci-mathematics/jags/ChangeLog
index b50d646883bb..3418cfe9ba79 100644
--- a/sci-mathematics/jags/ChangeLog
+++ b/sci-mathematics/jags/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/jags
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/ChangeLog,v 1.13 2013/08/12 21:47:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/ChangeLog,v 1.14 2013/09/04 19:03:54 bicatali Exp $
+
+*jags-3.4.0 (04 Sep 2013)
+
+ 04 Sep 2013; Sébastien Fabbro <bicatali@gentoo.org> +jags-3.4.0.ebuild:
+ Version bump
12 Aug 2013; Sébastien Fabbro <bicatali@gentoo.org> jags-3.3.0.ebuild,
metadata.xml:
diff --git a/sci-mathematics/jags/jags-3.4.0.ebuild b/sci-mathematics/jags/jags-3.4.0.ebuild
new file mode 100644
index 000000000000..7afacf248f1a
--- /dev/null
+++ b/sci-mathematics/jags/jags-3.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/jags-3.4.0.ebuild,v 1.1 2013/09/04 19:03:54 bicatali Exp $
+
+EAPI=5
+
+inherit autotools-utils toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="http://mcmc-jags.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/3.x/Source/${MYP}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo docs)
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc ${BUILD_DIR}/doc/manual/*.pdf
+}