summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/coq/coq-7.4.ebuild')
-rw-r--r--sci-mathematics/coq/coq-7.4.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/sci-mathematics/coq/coq-7.4.ebuild b/sci-mathematics/coq/coq-7.4.ebuild
deleted file mode 100644
index 34d6b1b16bab..000000000000
--- a/sci-mathematics/coq/coq-7.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-7.4.ebuild,v 1.3 2006/02/04 16:30:27 mattam Exp $
-
-inherit eutils
-
-DESCRIPTION="Coq is a proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
-IUSE="norealanalysis"
-
-DEPEND=">=dev-lang/ocaml-3.06
-!>=dev-lang/ocaml-3.08"
-
-src_compile() {
- local myconf="--prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/lib/coq \
- --mandir /usr/man \
- --emacslib /usr/share/emacs/site-lisp"
-
- use norealanalysis \
- && myconf="$myconf --reals" \
- || myconf="$myconf --reals all"
-
- has_version ">=dev-lang/ocaml-3.07" && epatch ${FILESDIR}/ocaml-3.07.patch
-
- ./configure $myconf || die
-
- emake world || die
-}
-
-src_install() {
- make COQINSTALLPREFIX=${D} install || die
- dodoc README CREDITS CHANGES
-}