summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/prints/prints-37.0.ebuild')
-rw-r--r--sci-biology/prints/prints-37.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sci-biology/prints/prints-37.0.ebuild b/sci-biology/prints/prints-37.0.ebuild
index 2fc7fa47d1c0..4a658fdbae14 100644
--- a/sci-biology/prints/prints-37.0.ebuild
+++ b/sci-biology/prints/prints-37.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/prints-37.0.ebuild,v 1.3 2005/02/02 21:32:12 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/prints-37.0.ebuild,v 1.4 2005/02/23 04:06:27 ribosome Exp $
DESCRIPTION="A protein motif fingerprint database"
HOMEPAGE="http://www.bioinf.man.ac.uk/dbbrowser/PRINTS/"
@@ -13,27 +13,29 @@ SRC_URI="ftp://ftp.ebi.ac.uk/pub/databases/${PN}/newpr.lis.gz
LICENSE="public-domain"
SLOT="0"
KEYWORDS="x86 ~ppc ppc-macos"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
S=${WORKDIR}
src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/printsextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PRINTS
+ echo
einfo "Indexing PRINTS for usage with EMBOSS."
EMBOSS_DATA=. printsextract -auto -infile prints37_0.dat || die \
"Indexing PRINTS failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}37_0.{all.fasta,dat,lis,nam,vsn} newpr.lis
fi
- if [ -e /usr/bin/printsextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PRINTS
doins PRINTS/*
fi