summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/biopython/biopython-1.64.ebuild')
-rw-r--r--sci-biology/biopython/biopython-1.64.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sci-biology/biopython/biopython-1.64.ebuild b/sci-biology/biopython/biopython-1.64.ebuild
deleted file mode 100644
index 09e531bc734d..000000000000
--- a/sci-biology/biopython/biopython-1.64.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.64.ebuild,v 1.2 2015/03/03 16:03:42 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="mysql postgres"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/reportlab[${PYTHON_USEDEP}]
- media-gfx/pydot[${PYTHON_USEDEP}]
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
-
-python_test() {
- cd Tests || die
- ${PYTHON} run_tests.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodir /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}