summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/galaxy/galaxy-2.0.ebuild')
-rw-r--r--sci-astronomy/galaxy/galaxy-2.0.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/sci-astronomy/galaxy/galaxy-2.0.ebuild b/sci-astronomy/galaxy/galaxy-2.0.ebuild
index 4f5057028064..3ded5d608e74 100644
--- a/sci-astronomy/galaxy/galaxy-2.0.ebuild
+++ b/sci-astronomy/galaxy/galaxy-2.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/galaxy-2.0.ebuild,v 1.1 2011/12/28 12:14:11 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/galaxy-2.0.ebuild,v 1.2 2011/12/28 12:21:18 xarthisius Exp $
EAPI=4
-inherit toolchain-funcs
+inherit fdo-mime toolchain-funcs
DESCRIPTION="stellar simulation program"
HOMEPAGE="http://kornelix.squarespace.com/galaxy/"
@@ -15,9 +15,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="x11-libs/gtk+:2
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
pkg_setup() {
tc-export CXX
@@ -25,5 +25,14 @@ pkg_setup() {
src_prepare() {
sed -e '/DOCDIR/ s/PROGRAM)/&-\$(VERSION)/g' \
+ -e '/xdg-desktop-menu/d' \
-i Makefile || die
}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}