summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_mp3/mod_mp3-0.40.ebuild')
-rw-r--r--net-www/mod_mp3/mod_mp3-0.40.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/net-www/mod_mp3/mod_mp3-0.40.ebuild b/net-www/mod_mp3/mod_mp3-0.40.ebuild
deleted file mode 100644
index 44debc8118c6..000000000000
--- a/net-www/mod_mp3/mod_mp3-0.40.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.40.ebuild,v 1.10 2006/01/26 02:06:11 gustavoz Exp $
-
-IUSE="mysql postgres"
-
-DESCRIPTION="Module for turning Apache into an MP3 or Ogg streaming server"
-HOMEPAGE="http://media.tangent.org/"
-KEYWORDS="ppc -sparc x86"
-
-SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
-
-DEPEND="virtual/libc
- =net-www/apache-1*
- dev-lang/perl
- mysql? ( >=dev-db/mysql-3.23.26 )
- postgres? ( dev-db/postgresql )"
-
-LICENSE="as-is"
-SLOT="0"
-
-src_compile() {
- local myconf
- use mysql && myconf="${myconf} --with-mysql"
- use postgres && myconf="${myconf} --with-postgres"
- ./configure ${myconf} || die
- make clean
- make || die "compile problem"
-}
-
-src_install() {
- exeinto /usr/lib/apache-extramodules
- doexe src/mod_mp3.so
-
- dodoc CONTRIBUTORS MANIFEST TODO ChangeLog LICENSE README VERSION
- dodoc support/{faq.pod,mp3_with_mysql.conf,mysql_schema,pgsql_schema}
- dohtml faq.html
-
- insinto /etc/apache/conf/addon-modules
- doins ${FILESDIR}/mod_mp3.conf
-}
-
-pkg_postinst() {
- einfo
- einfo "Execute \"ebuild /var/db/pkg/net-www/${PF}/${PF}.ebuild config\""
- einfo "to have your apache.conf auto-updated for use with this module."
- einfo "You should then edit your /etc/conf.d/apache file to suit."
- einfo
-}
-
-pkg_config() {
- ${ROOT}/usr/sbin/apacheaddmod \
- ${ROOT}/etc/apache/conf/apache.conf \
- extramodules/mod_mp3.so mod_mp3.c mp3_module \
- define=MP3 addconf=conf/addon-modules/mod_mp3.conf
- :;
-}