summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild b/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild
deleted file mode 100644
index 6445d58f2fcd..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild,v 1.7 2008/07/28 21:35:35 carlo Exp $
-
-EAPI=1
-
-inherit eutils qt4
-
-DESCRIPTION="BitTorrent client in C++ and Qt."
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE=""
-
-DEPEND="=net-libs/rb_libtorrent-0.12*
- =x11-libs/qt-4.3*:4
- >=dev-lang/python-2.3
- dev-libs/boost
- net-misc/curl"
-
-pkg_setup() {
- # We need boost built with threads
- if ! built_with_use --missing true "dev-libs/boost" threads; then
- eerror "${PN} needs dev-libs/boost built with threads USE flag"
- die "dev-libs/boost is built without threads USE flag"
- fi
-}
-
-src_compile() {
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr \
- --with-libtorrent-inc=/usr/include \
- --with-libtorrent-lib=/usr/lib \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc AUTHORS Changelog NEWS README TODO
-}