summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pam_smb/pam_smb-1.9.9-r1.ebuild')
-rw-r--r--net-misc/pam_smb/pam_smb-1.9.9-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/pam_smb/pam_smb-1.9.9-r1.ebuild b/net-misc/pam_smb/pam_smb-1.9.9-r1.ebuild
new file mode 100644
index 000000000000..a7e0bd725b7c
--- /dev/null
+++ b/net-misc/pam_smb/pam_smb-1.9.9-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pam_smb/pam_smb-1.9.9-r1.ebuild,v 1.1 2002/11/02 07:35:23 woodchip Exp $
+
+DESCRIPTION="The PAM SMB module, which allows authentication against an NT server."
+HOMEPAGE="http://www.csn.ul.ie/~airlied/pam_smb/"
+
+S=${WORKDIR}/${PN}
+SRC_URI="http://us2.samba.org/samba/ftp/pam_smb/devel/${P}.tar.gz"
+
+DEPEND=">=sys-libs/pam-0.75"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+src_compile() {
+ econf --disable-root-only || die
+ emake || die
+}
+
+src_install() {
+ exeinto /lib/security
+ doexe pamsmbm/pam_smb_auth.so
+ exeinto /usr/sbin
+ doexe pamsmbd/pamsmbd
+
+ dodoc BUGS CHANGES COPYING README TODO INSTALL \
+ faq/{pam_smb_faq.sgml,additions.txt}
+ docinto pam.d
+ dodoc pam_smb.conf*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pamsmbd-init pamsmbd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You must create /etc/pam_smb.conf yourself, containing"
+ einfo "your domainname, PDC and BDC. See example files in docdir."
+ einfo
+}