summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/amavis/amavis-0.2.1-r2.ebuild15
-rw-r--r--net-mail/courier-imap/courier-imap-1.3.8.ebuild16
-rw-r--r--net-mail/fetchmail/fetchmail-5.8.2.ebuild3
-rw-r--r--net-mail/maildrop/maildrop-1.2.2-r3.ebuild4
-rw-r--r--net-mail/mutt/mutt-1.2.5-r2.ebuild33
-rw-r--r--net-mail/postfix/postfix-20010228.2-r1.ebuild22
-rw-r--r--net-mail/vlnx/vlnx-407e-r1.ebuild4
7 files changed, 56 insertions, 41 deletions
diff --git a/net-mail/amavis/amavis-0.2.1-r2.ebuild b/net-mail/amavis/amavis-0.2.1-r2.ebuild
index 4ac2c30cea63..47cf63c9daa0 100644
--- a/net-mail/amavis/amavis-0.2.1-r2.ebuild
+++ b/net-mail/amavis/amavis-0.2.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/amavis/amavis-0.2.1-r2.ebuild,v 1.2 2001/02/01 19:30:33 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/amavis/amavis-0.2.1-r2.ebuild,v 1.3 2001/05/30 18:24:34 achim Exp $
A="${P}.tar.gz"
S=${WORKDIR}/${P}
@@ -10,15 +10,14 @@ SRC_URI="http://www.amavis.org/dist/${A}"
HOMEPAGE="http://www.amavis.org"
-DEPEND=">=sys-apps/bash-2.04
- >=sys-libs/glibc-2.1.3
+DEPEND="virtual/glibc
net-mail/maildrop
>=net-mail/tnef-0.13
>=net-mail/vlnx-407e
- virtual/mta"
+ net-mail/qmail"
+
+src_compile() {
-src_compile() {
- cd ${S}
./reconf
try ./configure --host=${CHOST} --prefix=/usr \
--with-logdir=/var/log/scanmail \
@@ -27,8 +26,8 @@ src_compile() {
try make
}
-src_install() {
- cd ${S}
+src_install() {
+
try make prefix=${D}/usr install
into /usr
dodoc AUTHORS BUGS COPYING ChangeLog FAQ HINTS NEWS README* TODO
diff --git a/net-mail/courier-imap/courier-imap-1.3.8.ebuild b/net-mail/courier-imap/courier-imap-1.3.8.ebuild
index 2d0f0486a314..0f95f85bb91b 100644
--- a/net-mail/courier-imap/courier-imap-1.3.8.ebuild
+++ b/net-mail/courier-imap/courier-imap-1.3.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-1.3.8.ebuild,v 1.1 2001/05/06 15:45:46 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-1.3.8.ebuild,v 1.2 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,12 +9,20 @@ DESCRIPTION="An IMAP daemon designed specifically for maildirs"
SRC_URI="http://download.sourceforge.net/courier/${A}"
HOMEPAGE="http://www.courier-mta.org/"
-DEPEND="virtual/glibc
- >=sys-libs/pam-0.75
+DEPEND="virtual/glibc sys-devel/perl sys-apps/procps
+ >=sys-libs/pam-0.75
>=dev-libs/openssl-0.9.6
ldap? ( >=net-nds/openldap-1.2.11 )
mysql? ( >=dev-db/mysql-3.23.36 )
- berkdb? ( >=sys-libs/db-1.8 )
+ berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/pam-0.75
+ >=dev-libs/openssl-0.9.6
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ mysql? ( >=dev-db/mysql-3.23.36 )
+ berkdb? ( >=sys-libs/db-3.2 )
gdbm? ( >=sys-libs/gdbm-1.8.0 )"
#This package is complete if you just need basic IMAP functionality. Here are some things that
diff --git a/net-mail/fetchmail/fetchmail-5.8.2.ebuild b/net-mail/fetchmail/fetchmail-5.8.2.ebuild
index 2013cca54714..1b71016ed9db 100644
--- a/net-mail/fetchmail/fetchmail-5.8.2.ebuild
+++ b/net-mail/fetchmail/fetchmail-5.8.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.8.2.ebuild,v 1.1 2001/05/10 02:16:02 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.8.2.ebuild,v 1.2 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -23,6 +23,7 @@ src_compile() {
myconf="$myconf --disable-nls"
fi
try ./configure --prefix=/usr --host=${CHOST} \
+ --mandir=/usr/share/man \
--enable-RPA --enable-NTLN \
--enable-SDPS $myconf
try make
diff --git a/net-mail/maildrop/maildrop-1.2.2-r3.ebuild b/net-mail/maildrop/maildrop-1.2.2-r3.ebuild
index 558c1ebbd852..12d3f355ef0d 100644
--- a/net-mail/maildrop/maildrop-1.2.2-r3.ebuild
+++ b/net-mail/maildrop/maildrop-1.2.2-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/maildrop/maildrop-1.2.2-r3.ebuild,v 1.2 2001/05/29 17:28:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/maildrop/maildrop-1.2.2-r3.ebuild,v 1.3 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,11 +10,13 @@ SRC_URI="http://download.sourceforge.net/courier/${A}"
HOMEPAGE="http://www.flounder.net/~mrsam/maildrop/index.html"
DEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.3
>=sys-libs/gdbm-1.8.0
virtual/mta
sys-devel/perl"
RDEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.3
>=sys-libs/gdbm-1.8.0
virtual/mta"
diff --git a/net-mail/mutt/mutt-1.2.5-r2.ebuild b/net-mail/mutt/mutt-1.2.5-r2.ebuild
index b9c914d730b1..428c0a43acef 100644
--- a/net-mail/mutt/mutt-1.2.5-r2.ebuild
+++ b/net-mail/mutt/mutt-1.2.5-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.2.5-r2.ebuild,v 1.1 2000/12/20 09:45:34 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.2.5-r2.ebuild,v 1.2 2001/05/30 18:24:34 achim Exp $
P=mutt-1.2.5-1
A=mutt-1.2.5i.tar.gz
@@ -10,18 +10,33 @@ DESCRIPTION="a small but very powerful text-based mail client"
SRC_URI="ftp://ftp.mutt.org/pub/mutt/${A}"
HOMEPAGE="http://www.mutt.org"
-DEPEND=">=sys-apps/bash-2.04
- >=sys-libs/glibc-2.1.3
- >=sys-libs/slang-1.4.2
- >=dev-libs/openssl-0.9.6"
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.2
+ slang? ( >=sys-libs/slang-1.4.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ slang? ( >=sys-libs/slang-1.4.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
src_compile() {
- cd ${S}
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --with-ssl"
+ fi
+ if [ "`use slang`" ] ; then
+ myconf="$myconf --with-slang"
+ fi
+
try ./configure --prefix=/usr --sysconfdir=/etc/mutt --host=${CHOST} \
- --with-slang --with-regex --with-catgets \
- --enable-pop --enable-imap --with-ssl --enable-nfs-fix \
- --with-homespool=Maildir
+ --with-regex --enable-pop --enable-imap --enable-nfs-fix \
+ --with-homespool=Maildir $myconf
try make
}
diff --git a/net-mail/postfix/postfix-20010228.2-r1.ebuild b/net-mail/postfix/postfix-20010228.2-r1.ebuild
index e04ab2265556..920b242aa8e0 100644
--- a/net-mail/postfix/postfix-20010228.2-r1.ebuild
+++ b/net-mail/postfix/postfix-20010228.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-20010228.2-r1.ebuild,v 1.1 2001/05/14 15:57:35 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-20010228.2-r1.ebuild,v 1.2 2001/05/30 18:24:34 achim Exp $
P=${PN}-20010228-pl02
A=${P}.tar.gz
@@ -10,15 +10,15 @@ DESCRIPTION="A fast and secure drop-in replacement for sendmail"
SRC_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/official/${A}"
HOMEPAGE="http://www.postfix.org/"
-DEPEND=">=net-mail/mailbase-0.00
+DEPEND="virtual/glibc
>=dev-libs/libpcre-3.4
- >=sys-libs/glibc-2.1.3"
+ >=sys-libs/db-3.2
+ mta-ldap? ( >=net-nds/openldap-1.2 )
+ mta-mysql? ( >=dev-db/mysql-3.23.28 )"
-RDEPEND="!virtual/mta"
+RDEPEND="!virtual/mta >=net-mail/mailbase-0.00 $DEPEND"
TLS_DEP=">=dev-libs/openssl-0.9.6"
-LDAP_DEP=">=net-nds/openldap-1.2"
-MYSQL_DEP=">=dev-db/mysql-3.23.28"
#TLS_URI=
@@ -27,16 +27,6 @@ MYSQL_DEP=">=dev-db/mysql-3.23.28"
# echo $DEPEND
#fi
-if [ -n "`use mta-ldap`" ]; then
- DEPEND="${DEPEND} ${LDAP_DEP}"
- echo $DEPEND
-fi
-
-if [ -n "`use mta-mysql`" ]; then
- DEPEND="${DEPEND} ${MYSQL_DEP}"
- echo $DEPEND
-fi
-
PROVIDE="virtual/mta"
src_unpack() {
diff --git a/net-mail/vlnx/vlnx-407e-r1.ebuild b/net-mail/vlnx/vlnx-407e-r1.ebuild
index acbf7730bf1f..32d4c9994717 100644
--- a/net-mail/vlnx/vlnx-407e-r1.ebuild
+++ b/net-mail/vlnx/vlnx-407e-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vlnx/vlnx-407e-r1.ebuild,v 1.3 2000/11/01 04:44:20 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vlnx/vlnx-407e-r1.ebuild,v 1.4 2001/05/30 18:24:34 achim Exp $
P=vlnx407e
A="${P}.tar.Z dat-4098.tar"
@@ -12,7 +12,7 @@ SRC_URI="http://download.mcafee.com/products/evaluation/virusscan/english/unix/l
http://download.nai.com/products/datfiles/4.x/nai/dat-4098.tar"
DEPEND=""
-
+RDEPEND="sys-devel/ld.so"
src_unpack() {
cd ${WORKDIR}
mkdir ${P}