summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mozilla-thunderbird/files/enigmail/Makefile-ipc')
-rw-r--r--net-mail/mozilla-thunderbird/files/enigmail/Makefile-ipc51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/mozilla-thunderbird/files/enigmail/Makefile-ipc b/net-mail/mozilla-thunderbird/files/enigmail/Makefile-ipc
new file mode 100644
index 000000000000..99c2231f3d0c
--- /dev/null
+++ b/net-mail/mozilla-thunderbird/files/enigmail/Makefile-ipc
@@ -0,0 +1,51 @@
+#!gmake
+#
+# The contents of this file are subject to the Mozilla Public
+# License Version 1.1 (the "MPL"); you may not use this file
+# except in compliance with the MPL. You may obtain a copy of
+# the MPL at http://www.mozilla.org/MPL/
+#
+# Software distributed under the MPL is distributed on an "AS
+# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
+# implied. See the MPL for the specific language governing
+# rights and limitations under the MPL.
+#
+# The Original Code is protoZilla.
+#
+# The Initial Developer of the Original Code is Ramalingam Saravanan.
+# Portions created by Ramalingam Saravanan <svn@xmlterm.org> are
+# Copyright (C) 2001 Ramalingam Saravanan. All Rights Reserved.
+#
+# Contributor(s):
+#
+# Alternatively, the contents of this file may be used under the
+# terms of the GNU General Public License (the "GPL"), in which case
+# the provisions of the GPL are applicable instead of
+# those above. If you wish to allow use of your version of this
+# file only under the terms of the GPL and not to allow
+# others to use your version of this file under the MPL, indicate
+# your decision by deleting the provisions above and replace them
+# with the notice and other provisions required by the GPL.
+# If you do not delete the provisions above, a recipient
+# may use your version of this file under either the MPL or the
+# GPL.
+#
+
+DEPTH = ../..
+topsrcdir = ../..
+srcdir = .
+VPATH = .
+
+include $(DEPTH)/config/autoconf.mk
+
+DIRS = public src
+
+ifdef BUILD_IPC
+DIRS += build
+endif
+
+ifdef ENABLE_TESTS
+DIRS += tests
+endif
+
+include $(topsrcdir)/config/rules.mk