summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gupnp/gupnp-0.6.ebuild')
-rw-r--r--net-libs/gupnp/gupnp-0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/gupnp/gupnp-0.6.ebuild b/net-libs/gupnp/gupnp-0.6.ebuild
new file mode 100644
index 000000000000..81cf4cfc0f11
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/gupnp-0.6.ebuild,v 1.1 2007/09/24 16:41:52 drac Exp $
+
+DESCRIPTION="an object-oriented framework for creating UPnP devs and control points."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://${PN}.org/sources/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND=">=net-libs/gssdp-0.3
+ >=net-libs/libsoup-2.2
+ dev-libs/libxml2
+ x11-misc/shared-mime-info
+ sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+ econf $(use_enable doc gtk-doc)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc || rm -rf "${D}"/usr/share/gtk-doc/html/${PN}
+}